Bug 1316005 - RFE: Hardware Enablement: Intel P530 IGP for skylake family processors
RFE: Hardware Enablement: Intel P530 IGP for skylake family processors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.8
All Linux
high Severity high
: rc
: ---
Assigned To: Lyude
Desktop QE
: FutureFeature
Depends On:
Blocks: 1269194 1360926
  Show dependency treegraph
 
Reported: 2016-03-09 03:46 EST by amit yadav
Modified: 2017-03-28 09:25 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-13 15:06:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2193961 None None None 2016-03-09 04:13 EST

  None (edit)
Description amit yadav 2016-03-09 03:46:08 EST
Description of problem:

Enable support for Intel P530 graphics(Skylake family APUs) in xorg-x11-drv-intel driver available in RHEL6

Version-Release number of selected component (if applicable):
Current release

How reproducible:
Always

Steps to Reproduce:
None

Actual results:
When installing RHEL6.7 on system with Intel P530 graphics(Skylake family APUs) 
Xorg is falling back to vesa.

Expected results:
Xorg should use xorgorg intel video driver.

Additional info:
Similar issue was found on RHEL7.2 and a RFE is filed for that.
https://bugzilla.redhat.com/show_bug.cgi?id=1306841
Comment 4 support.linux 2016-07-01 04:58:58 EDT
High.
We don't have any news of the support for this problem which is now a high problem for us because computers are arriving in our divisions and we don't have a solution to propose.
Can you tell us if you are working on it and if we will have a solution and when.
Regards
Comment 11 Lyude 2016-10-05 12:08:51 EDT
RHEL 6.7 never had SKL support, but RHEL 6.8 did. I'm pretty sure this was one of the original platforms I tested the RHEL68 backport on so this should be supported now. Can you verify?
Comment 12 amit yadav 2016-10-05 14:15:44 EDT
(In reply to Lyude from comment #11)
> RHEL 6.7 never had SKL support, but RHEL 6.8 did. I'm pretty sure this was
> one of the original platforms I tested the RHEL68 backport on so this should
> be supported now. Can you verify?

Requested customer to to try latest RHEL6.8 on his system and check status.
I will update you once I get response from him.
Comment 13 Lyude 2016-10-18 14:52:19 EDT
(In reply to amit yadav from comment #12)
> (In reply to Lyude from comment #11)
> > RHEL 6.7 never had SKL support, but RHEL 6.8 did. I'm pretty sure this was
> > one of the original platforms I tested the RHEL68 backport on so this should
> > be supported now. Can you verify?
> 
> Requested customer to to try latest RHEL6.8 on his system and check status.
> I will update you once I get response from him.

Any update on this?
Comment 15 linferna 2016-11-28 03:22:21 EST
I installed rhel6.8 on hp elitebook 850. I noticed with rhel 6.8, it recognized the graphic driver as ---> VGA compatible controller: Intel Corporation HD Graphics 520 (rev.07). When I installed rhel 6.7, it recognized the driver as Intel Sky Lake, and the performance & the resolution is inferior. 

With rhel 6.8, video associated kernel module is "i915". 

As I understand, the Sky Lake is Intel CPU family, where the graphic processor is built on the same CPU in this micro-architecture. I suspect, rhel 6.7 it installs the default driver, with rhel 6.8 it installs the correct driver. It is quite noticeable the performance and the resolution. Also, I installed rhel 6.8 in EFI/UEFI mode. 

Does this mean rhel 6.8 supports the sky lake family - built in graphic processor chips in Intel Sky Lake family?
Comment 16 Lyude 2016-12-13 15:05:35 EST
(In reply to linferna from comment #15)
> I installed rhel6.8 on hp elitebook 850. I noticed with rhel 6.8, it
> recognized the graphic driver as ---> VGA compatible controller: Intel
> Corporation HD Graphics 520 (rev.07). When I installed rhel 6.7, it
> recognized the driver as Intel Sky Lake, and the performance & the
> resolution is inferior. 
> 
> With rhel 6.8, video associated kernel module is "i915". 
> 
> As I understand, the Sky Lake is Intel CPU family, where the graphic
> processor is built on the same CPU in this micro-architecture. I suspect,
> rhel 6.7 it installs the default driver, with rhel 6.8 it installs the
> correct driver. It is quite noticeable the performance and the resolution.
> Also, I installed rhel 6.8 in EFI/UEFI mode. 
> 
> Does this mean rhel 6.8 supports the sky lake family - built in graphic
> processor chips in Intel Sky Lake family?

Yes, with no graphics driver loaded you won't have graphics acceleration, hence the lower performance. As well SKL wasn't supported until RHEL6.8 was released, so you're right.

Note You need to log in before you can comment on or make changes to this bug.