Bug 1316137 - A copy of custom alert replace your custom alert
A copy of custom alert replace your custom alert
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.3
Assigned To: Harpreet Kataria
Dmitry Misharov
: ZStream
Depends On: 1315377
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 09:01 EST by John Prause
Modified: 2017-08-29 22:05 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, copying a custom alert to create a new custom alert would result in replacing the existing alert with the new alert instead. This was due to a bug in the alert code logic which mistook the copy request as an edit request. This bug was fixed by correcting the logic to handle copying custom alerts correctly. Creating new custom alerts by copying existing custom alerts works as expected in the new version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1315377
Environment:
Last Closed: 2016-04-13 14:46:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 CFME Bot 2016-03-11 09:59:33 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=b862553d5c36e67551f0945031e0543fbc6e66e8

commit b862553d5c36e67551f0945031e0543fbc6e66e8
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Mar 8 11:10:48 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Mar 11 09:13:17 2016 -0500

    When copying an alert record dont copy id of the record.
    
    Presence of id in @alert was causing UI to think that existing record is being edited instead a new copied record being added. Due to this incorrect cell title and form buttons were displayed on screen.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1315377
    https://bugzilla.redhat.com/show_bug.cgi?id=1316137
    (cherry picked from commit 9ce911e)

 app/controllers/miq_policy_controller/alerts.rb    |  4 +--
 .../miq_policy_controller/alerts_spec.rb           | 29 ++++++++++++++++++++++
 2 files changed, 31 insertions(+), 2 deletions(-)
 create mode 100644 spec/controllers/miq_policy_controller/alerts_spec.rb
Comment 4 CFME Bot 2016-03-11 09:59:52 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=93869904e2e13e9014bf545d98b6543faf9fcb1a

commit 93869904e2e13e9014bf545d98b6543faf9fcb1a
Merge: 564108e b862553
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Mar 11 09:52:47 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Mar 11 09:52:47 2016 -0500

    Merge branch '55z_pr_7158' into '5.5.z'
    
    When copying an alert record dont copy id of the record.
    
    Presence of id in @alert was causing UI to think that existing record is being edited instead a new copied record being added. Due to this incorrect cell title and form buttons were displayed on screen.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1315377
    https://bugzilla.redhat.com/show_bug.cgi?id=1316137
    (cherry picked from commit 9ce911e)
    
    @dclarizi please review/merge, this is clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/7158
    
    See merge request !844

 app/controllers/miq_policy_controller/alerts.rb    |  4 +--
 .../miq_policy_controller/alerts_spec.rb           | 29 ++++++++++++++++++++++
 2 files changed, 31 insertions(+), 2 deletions(-)
Comment 6 Dmitry Misharov 2016-03-29 03:02:41 EDT
Verified and working fine in version 5.5.3.2.20160318152106_92d2d67. A copy of custom alert doesn't replace the original alert.
Comment 8 errata-xmlrpc 2016-04-13 14:46:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.