Bug 1315377 - A copy of custom alert replace your custom alert
A copy of custom alert replace your custom alert
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Dmitry Misharov
alert
: ZStream
: 1303645 1315450 (view as bug list)
Depends On:
Blocks: 1316137
  Show dependency treegraph
 
Reported: 2016-03-07 10:25 EST by kpichard
Modified: 2016-06-29 11:40 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1316137 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:40:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kpichard 2016-03-07 10:25:10 EST
Description of problem:
When you copy an already custom alert in cf, it replace your current custom alert. 

Version-Release number of selected component (if applicable): 5.5.2.4


How reproducible:
every time


Steps to Reproduce:
1. go to alert and create a new one
2. Copy this new custom alert into another name

Actual results:
It replace your alert not making a copy


Expected results:
Copy your alert into another one

Additional info:
Comment 2 Greg McCullough 2016-03-07 16:07:49 EST
*** Bug 1315450 has been marked as a duplicate of this bug. ***
Comment 3 Harpreet Kataria 2016-03-08 15:49:32 EST
https://github.com/ManageIQ/manageiq/pull/7158
Comment 4 CFME Bot 2016-03-09 04:20:35 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/9ce911e887f7eb08fdee6a463b0e9f36d50e332b

commit 9ce911e887f7eb08fdee6a463b0e9f36d50e332b
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Mar 8 11:10:48 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Mar 8 15:50:30 2016 -0500

    When copying an alert record dont copy id of the record.
    
    Presence of id in @alert was causing UI to think that existing record is being edited instead a new copied record being added. Due to this incorrect cell title and form buttons were displayed on screen.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1315377

 app/controllers/miq_policy_controller/alerts.rb    |  4 +--
 .../miq_policy_controller/alerts_spec.rb           | 29 ++++++++++++++++++++++
 2 files changed, 31 insertions(+), 2 deletions(-)
 create mode 100644 spec/controllers/miq_policy_controller/alerts_spec.rb
Comment 6 CFME Bot 2016-03-11 09:59:29 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=b862553d5c36e67551f0945031e0543fbc6e66e8

commit b862553d5c36e67551f0945031e0543fbc6e66e8
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Tue Mar 8 11:10:48 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Mar 11 09:13:17 2016 -0500

    When copying an alert record dont copy id of the record.
    
    Presence of id in @alert was causing UI to think that existing record is being edited instead a new copied record being added. Due to this incorrect cell title and form buttons were displayed on screen.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1315377
    https://bugzilla.redhat.com/show_bug.cgi?id=1316137
    (cherry picked from commit 9ce911e)

 app/controllers/miq_policy_controller/alerts.rb    |  4 +--
 .../miq_policy_controller/alerts_spec.rb           | 29 ++++++++++++++++++++++
 2 files changed, 31 insertions(+), 2 deletions(-)
 create mode 100644 spec/controllers/miq_policy_controller/alerts_spec.rb
Comment 7 CFME Bot 2016-03-11 09:59:47 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=93869904e2e13e9014bf545d98b6543faf9fcb1a

commit 93869904e2e13e9014bf545d98b6543faf9fcb1a
Merge: 564108e b862553
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Mar 11 09:52:47 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Mar 11 09:52:47 2016 -0500

    Merge branch '55z_pr_7158' into '5.5.z'
    
    When copying an alert record dont copy id of the record.
    
    Presence of id in @alert was causing UI to think that existing record is being edited instead a new copied record being added. Due to this incorrect cell title and form buttons were displayed on screen.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1315377
    https://bugzilla.redhat.com/show_bug.cgi?id=1316137
    (cherry picked from commit 9ce911e)
    
    @dclarizi please review/merge, this is clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/7158
    
    See merge request !844

 app/controllers/miq_policy_controller/alerts.rb    |  4 +--
 .../miq_policy_controller/alerts_spec.rb           | 29 ++++++++++++++++++++++
 2 files changed, 31 insertions(+), 2 deletions(-)
Comment 8 Harpreet Kataria 2016-03-14 09:10:35 EDT
*** Bug 1303645 has been marked as a duplicate of this bug. ***
Comment 9 Dmitry Misharov 2016-04-12 02:33:27 EDT
Tested and verified in 5.6.0.0-beta1.20160322143549_f7ea680.
Comment 11 errata-xmlrpc 2016-06-29 11:40:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.