Bug 1316250 - Gnome3 X Session mouse disappears when hovering over activities bar or other shell components
Gnome3 X Session mouse disappears when hovering over activities bar or other ...
Status: CLOSED DUPLICATE of bug 1315938
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
23
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 14:00 EST by Jacob Keller
Modified: 2016-03-10 10:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 10:52:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacob Keller 2016-03-09 14:00:41 EST
Description of problem:

After the most recent update, when using the regular Gnome3 session running on X, If I hover the mouse over any of the Gnome shell components (activities bar, or the hidden application tray, or anywhere when inside the activities menu), the mouse pointer disappears. The mouse functions correctly, you just can't view the pointer, which makes it hard to navigate.


Version-Release number of selected component (if applicable):
Not sure which component would be the issue, but I have
gnome-session-3.18.1.2-2
xorg-x11-server-Xorg-1.18.0-2

I am using the nouveau driver, from kernel 4.4.3-300

libinput-1.2.1-2
xorg-x11-drv-libinput-0.16.0-1

Can provide other information if necessary.


How reproducible:
Reproduces in regular "Gnome" session. Does not reproduce when using Gnome on Wayland. Reproduces every time after the most recent upgrade, not sure which package would have broken this.


Steps to Reproduce:
1. Login to Gnome session
2. Hover mouse over activities bar.

Actual results:
Cursor is invisible, making it hard to navigate the mouse.


Expected results:
Cursor remains visible.


Additional info:

The fresh fedora 23 install did not have the issue, it only started occurring recently. I had it happen on one fedora 23 install that had been upgrading over time, and another fresh fedora installation with the same hardware, issue only occuring after the update process.
Comment 1 Uwe Köcher 2016-03-10 04:08:06 EST
looks like a duplicate, cf. #1315938

https://bugzilla.redhat.com/show_bug.cgi?id=1315938
Comment 2 Ray Strode [halfline] 2016-03-10 10:52:57 EST

*** This bug has been marked as a duplicate of bug 1315938 ***

Note You need to log in before you can comment on or make changes to this bug.