Bug 1316279 - need deprecation script to show error message when users run 'katello-installer'
need deprecation script to show error message when users run 'katello-installer'
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Brad Buckingham
jcallaha
http://projects.theforeman.org/issues...
: Triaged, UserExperience
: 1316305 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker/GSS_Sat6_Tracker
  Show dependency treegraph
 
Reported: 2016-03-09 16:20 EST by Mike McCune
Modified: 2016-07-27 05:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:05:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14416 None None None 2016-04-22 12:37 EDT

  None (edit)
Description Mike McCune 2016-03-09 16:20:35 EST
To assist users with Satellite 6.2's new installation routine we need a shell script for 'katello-installer' that just exits with an error stating:

# katello-installer
ERROR: katello-installer is no longer used. Please see foreman-installer

if we decide to re-brand to 'satellite-installer' have it point at the new command.
Comment 3 Mike McCune 2016-03-10 11:08:02 EST
*** Bug 1316305 has been marked as a duplicate of this bug. ***
Comment 5 Brad Buckingham 2016-03-31 07:40:06 EDT
Created redmine issue http://projects.theforeman.org/issues/14416 from this bug
Comment 6 Bryan Kearney 2016-03-31 10:23:52 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14416 has been closed
-------------
Brad Buckingham
Applied in changeset commit:katello-installer|843be62c64ffd559518c7d4757530b15f21609d2.
Comment 7 Brad Buckingham 2016-03-31 10:52:53 EDT
I am moving this back to assigned.  We need the packaging changes upstream as well, before this can go to POST.

The fix will be 2 commits (one to katello-installer and one to katello-packaging).
Comment 8 Brad Buckingham 2016-04-01 10:37:55 EDT
Both PRs have now been merged; therefore, moving bugzilla to POST.
Comment 9 jcallaha 2016-04-06 15:17:22 EDT
Verified in Satellite 6.2 Beta Snap 6 compose 2.

ERROR: katello-installer is no longer used.  Please use 'foreman-installer --scenario katello'.
       For more information on available options, include '--help'.
Comment 11 errata-xmlrpc 2016-07-27 05:05:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.