Bug 1316305 - Satellite 6.2: make katello-installer a NOOP with error message pointing to new installer program foreman-installer
Satellite 6.2: make katello-installer a NOOP with error message pointing to n...
Status: CLOSED DUPLICATE of bug 1316279
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: UserExperience
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-09 17:51 EST by Xixi
Modified: 2016-03-10 11:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 11:08:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2016-03-09 17:51:38 EST
Description of problem:
Starting with Satellite 6.2 the installer program will be foreman-installer instead of previous katello-installer.  We need to make katello-installer a command that fails with a message informing user of this change and to run foreman-installer instead.

Version-Release number of selected component (if applicable):
Satellite 6.2.0

How reproducible:
always

Steps to Reproduce:
1. run katello-installer
2.
3.

Actual results:
command no longer found

Expected results:
a message stating katello-installer has been replaced by foreman-installer as of Satellite 6.2 and to run that instead

Additional info:
Comment 2 Mike McCune 2016-03-10 11:08:02 EST

*** This bug has been marked as a duplicate of bug 1316279 ***

Note You need to log in before you can comment on or make changes to this bug.