Bug 1316437 - snapd doesn't come up automatically after node reboot.
snapd doesn't come up automatically after node reboot.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Avra Sengupta
: Triaged, ZStream
Depends On: 1289439
Blocks: 1316806
  Show dependency treegraph
 
Reported: 2016-03-10 04:04 EST by Avra Sengupta
Modified: 2016-06-16 09:59 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1289439
: 1316806 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:59:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-10 04:15:12 EST
REVIEW: http://review.gluster.org/13665 (snapshot: Use svc->manager during glusterd restart) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Vijay Bellur 2016-03-11 03:05:34 EST
COMMIT: http://review.gluster.org/13665 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 07a5d9e1e103c8e3ab69283711ee0832d469e145
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Thu Mar 10 14:32:03 2016 +0530

    snapshot: Use svc->manager during glusterd restart
    
    Instead of using svc->start, we should use svc->manager
    as it takes care of initializing svc too, and both starts
    and stops snapd as needed.
    
    Change-Id: I3d3afdf4c4203bee3b790a017b820339fd376af6
    BUG: 1316437
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/13665
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:59:45 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.