Bug 1316806 - snapd doesn't come up automatically after node reboot.
snapd doesn't come up automatically after node reboot.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
3.7.9
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Avra Sengupta
: Triaged, ZStream
Depends On: 1289439 1316437
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 03:07 EST by Avra Sengupta
Modified: 2016-04-19 02:59 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1316437
Environment:
Last Closed: 2016-04-19 02:59:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-03-11 03:07:55 EST
REVIEW: http://review.gluster.org/13675 (snapshot: Use svc->manager during glusterd restart) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)
Comment 2 Vijay Bellur 2016-03-22 03:48:08 EDT
COMMIT: http://review.gluster.org/13675 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 918436e5b587588e285809bf56b241c90cf942c3
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Thu Mar 10 14:32:03 2016 +0530

    snapshot: Use svc->manager during glusterd restart
    
        Backport of http://review.gluster.org/#/c/13665/
    
    Instead of using svc->start, we should use svc->manager
    as it takes care of initializing svc too, and both starts
    and stops snapd as needed.
    
    Change-Id: I3d3afdf4c4203bee3b790a017b820339fd376af6
    BUG: 1316806
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/13665
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    (cherry picked from commit 07a5d9e1e103c8e3ab69283711ee0832d469e145)
    Reviewed-on: http://review.gluster.org/13675
Comment 3 Kaushal 2016-04-19 02:59:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.10, please open a new bug report.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.