Bug 1316471 - [4.0] Traceback upgrading reports to master
[4.0] Traceback upgrading reports to master
Status: CLOSED WONTFIX
Product: ovirt-engine-reports
Classification: oVirt
Component: Setup (Show other bugs)
4.0
Unspecified Unspecified
urgent Severity urgent (vote)
: ---
: ---
Assigned To: Yedidyah Bar David
Pavel Stehlik
:
Depends On:
Blocks: RHEV_from_3_6_to_4_0_Migration_Tracker
  Show dependency treegraph
 
Reported: 2016-03-10 05:54 EST by Sandro Bonazzola
Modified: 2017-05-11 05:28 EDT (History)
1 user (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-15 05:04:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sbonazzo: ovirt‑4.1?
rule-engine: planning_ack+
sbonazzo: devel_ack+
sbonazzo: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54686 master MERGED packaging: setup: use shared code from ovirt_setup_lib 2016-03-17 06:07 EDT

  None (edit)
Description Sandro Bonazzola 2016-03-10 05:54:55 EST
Description of problem:
***L:ERROR Internal error: cannot import name dialog
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/__main__.py", line 103, in main
    installer.execute()
  File "/usr/lib/python2.7/site-packages/otopi/main.py", line 163, in execute
    sys.exc_info()[2],
  File "/usr/lib/python2.7/site-packages/otopi/util.py", line 96, in raiseExceptionInformation
    exec('raise info[1], None, info[2]')
  File "/usr/lib/python2.7/site-packages/otopi/main.py", line 157, in execute
    self.context.loadPlugins()
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 538, in loadPlugins
    self._loadPluginGroups(plugindir, needgroups, loadedgroups)
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 127, in _loadPluginGroups
    self._loadPlugins(path, path, groupname)
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 84, in _loadPlugins
    self._loadPlugins(base, d, groupname)
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 84, in _loadPlugins
    self._loadPlugins(base, d, groupname)
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 115, in _loadPlugins
    os.path.basename(path),
  File "/usr/lib/python2.7/site-packages/otopi/util.py", line 120, in loadModule
    mod_desc
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine-reports/config/__init__.py", line 22, in <module>
    from . import admin
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine-reports/config/admin.py", line 27, in <module>
    from ovirt_engine_setup import dialog
PluginLoadException: cannot import name dialog
Comment 1 Sandro Bonazzola 2016-05-05 08:47:07 EDT
re-targeting to 4.1 since 4.0 won't have reports.

Note You need to log in before you can comment on or make changes to this bug.