Bug 1316511 - OData - missing non-nullable property
OData - missing non-nullable property
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.3.0
Unspecified Unspecified
medium Severity medium
: ER4
: 6.3.0
Assigned To: Van Halbert
Juraj Duráni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 06:29 EST by Juraj Duráni
Modified: 2016-08-24 07:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:47:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-4064 Major Closed OData - missing non-nullable property 2016-06-15 08:34 EDT

  None (edit)
Description Juraj Duráni 2016-03-10 06:29:15 EST
Description of problem:
DDL for tables Customer and Orders in VDB as follows:
CREATE FOREIGN TABLE Customers (
  id integer PRIMARY KEY OPTIONS (NAMEINSOURCE 'id'),
  name varchar(10)) OPTIONS (NAMEINSOURCE 'DB.PUBLIC.CUSTOMERS');
CREATE FOREIGN TABLE Orders (
  id integer PRIMARY KEY OPTIONS (NAMEINSOURCE 'id'),
  customerid integer,
  place varchar(10),
  FOREIGN KEY (customerid) REFERENCES Customers(id)) OPTIONS (NAMEINSOURCE 'DB.PUBLIC.ORDERS');

Note, that both tables have same name of primary key named "id".

Invoke GET method to URL http://localhost:8080/odata4/olingo_basic/Source/Customers/?$count=true&$expand=Orders_FK0

*Result:* The non-nullable property 'id' is missing.

Here are selected part of Teiid's log:
*Query:*
SELECT g10.id, g10.name, g11.id, g11.customerid, g11.place FROM Source.Customers AS g10 LEFT OUTER JOIN Source.Orders AS g11 ON g10.id = g11.customerid ORDER BY g10.id
*Result:*
|id|name     |id    |customerid|place  |
|--|---------|------|----------|-------|
|1 |customer1|1     |1         |town   |
|1 |customer1|2     |1         |state  |
|1 |customer1|3     |1         |country|
|1 |customer1|4     |1         |abroad |
|2 |customer2|5     |2         |state  |
|2 |customer2|6     |2         |country|
|3 |customer3|7     |3         |town   |
|3 |customer3|8     |3         |town   |
|4 |customer4|<null>|<null>    |<null> |
Comment 1 JBoss JIRA Server 2016-03-18 11:22:33 EDT
Ramesh Reddy <rareddy@jboss.org> updated the status of jira TEIID-4064 to Coding In Progress
Comment 2 Van Halbert 2016-03-18 14:19:58 EDT
*** Bug 1316476 has been marked as a duplicate of this bug. ***
Comment 3 JBoss JIRA Server 2016-03-21 13:03:52 EDT
Ramesh Reddy <rareddy@jboss.org> updated the status of jira TEIID-4064 to Resolved
Comment 4 JBoss JIRA Server 2016-04-21 02:35:09 EDT
Juraj Duráni <jdurani@redhat.com> updated the status of jira TEIID-4064 to Reopened
Comment 5 Juraj Duráni 2016-04-21 02:35:45 EDT
The issue has not been fixed. Teiid throws NPE.
Comment 6 JBoss JIRA Server 2016-04-25 08:54:59 EDT
Ramesh Reddy <rareddy@jboss.org> updated the status of jira TEIID-4064 to Resolved
Comment 7 JBoss JIRA Server 2016-06-15 08:34:33 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-4064 to Closed

Note You need to log in before you can comment on or make changes to this bug.