Bug 1316599 - [RFE][swift] Reverse Object Listing
[RFE][swift] Reverse Object Listing
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-swift (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity unspecified
: ga
: 9.0 (Mitaka)
Assigned To: Pete Zaitcev
Mike Abrams
https://blueprints.launchpad.net/swif...
upstream_milestone_none upstream_defi...
: FutureFeature
: 1316597 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 09:53 EST by Sean Cohen
Modified: 2016-08-11 08:14 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-swift-2.7.0-2.el7ost
Doc Type: Enhancement
Doc Text:
This enhancement adds the ability to tell the container or account server to reverse the object listings. This capability allows you to break out versioned objects in middleware. As a result, the internal architecture is reorganized for safety reasons; in addition, reverse listings are available to client applications, if needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 08:14:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 120709 None None None 2016-03-10 09:53 EST

  None (edit)
Description Sean Cohen 2016-03-10 09:53:21 EST
This change adds the ability to tell the container or account server to reverse their listings. This is done by sending a reverse=TRUE_VALUE, Where TRUE_VALUE is one of the values true can be in common/utils: TRUE_VALUES = set(('true', '1', 'yes', 'on', 't', 'y')) For example: curl -i -X GET -H "X-Auth-Token: $TOKEN" $STORAGE_URL/c/?reverse=on
Comment 1 Sean Cohen 2016-03-22 22:43:03 EDT
*** Bug 1316597 has been marked as a duplicate of this bug. ***
Comment 2 Mike McCune 2016-03-28 19:47:57 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 3 Christian Schwede (cschwede) 2016-05-10 12:00:23 EDT
This feature has been added to the Mitaka release: https://github.com/openstack/swift/blob/master/CHANGELOG#L162
Comment 8 errata-xmlrpc 2016-08-11 08:14:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1597.html

Note You need to log in before you can comment on or make changes to this bug.