Bug 131675 - NetworkManager applet doesn't allow applet context menu to be invoked
NetworkManager applet doesn't allow applet context menu to be invoked
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
: 134651 (view as bug list)
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-02 22:29 EDT by Matthias Clasen
Modified: 2013-04-02 00:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 11:40:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2004-09-02 22:29:30 EDT
There is no way to remove the wireless applet with the mouse, since
you can't bring up the context menu. The applet is just a menubar, and
clicking anywhere on it with any button just brings up the applets
menu, not the context menu. It can probably still be removed using
keynav, but the applet should really have a handle similar to the
handle of the notification area or the window list, for easier
removal/dragging.
Comment 1 Bill Nottingham 2004-09-02 22:35:20 EDT
See also 131652 - no reason to fix one if we're removing it. :)
Comment 2 Mark McLoughlin 2004-09-03 04:57:50 EDT
Okay, this is the NetworkManager applet ... which really needs its own
bugzilla component
Comment 3 Mark McLoughlin 2004-09-03 05:02:51 EDT
The way other applets like this do it is to make button press events
which aren't from button 1 to be left for the applet to handle - e.g.
from the show desktop applet:

static gboolean
do_not_eat_button_press (GtkWidget      *widget,
                         GdkEventButton *event)
{
        if (event->button != 1) {
                g_signal_stop_emission_by_name (widget, 
                                                "button_press_event");
        }

        return FALSE;
}

{
        g_signal_connect (G_OBJECT (sdd->button),                    
                          "button_press_event",
                          G_CALLBACK (do_not_eat_button_press), NULL);
}
Comment 4 Dan Williams 2004-09-07 00:55:28 EDT
Mark,

The applet used to have this code until Seth converted it from a
Toggle Button to an actual Menu.  You can get the context-menu if you
click either the very top (if on a top-panel) or the very-bottom (on a
bottom-panel) of the applet's panel presence, but this needs to happen
regardless of where on it you click.  Does the above method still work
for GtkMenuBar/GtkMenuItem/GtkMenu objects?  The code still might be
there.

Reassign to Seth since he touched it last :)
Comment 5 Mark McLoughlin 2004-09-07 02:23:51 EDT
Yeah, I think that works for a menu bar too. The panel itself does
something similar - see menu_dummy_button_press_event()

Note, the fact that you can popup the menu at the top and bottom is
indicative of another problem - the applet doesn't expand itself to
come flush up against the edge which means you don't take advantage of
the pinning action of the edge of the screen.
Comment 6 Mark McLoughlin 2004-09-24 10:57:37 EDT
jrb's working on this now, right? *bounce*
Comment 7 Mark McLoughlin 2004-10-05 09:41:38 EDT
*** Bug 134651 has been marked as a duplicate of this bug. ***
Comment 8 Jonathan Blandford 2004-10-14 11:40:58 EDT
It's no longer an applet. 

Note You need to log in before you can comment on or make changes to this bug.