Bug 131677 - "segfault" when trying to load any module.
Summary: "segfault" when trying to load any module.
Status: CLOSED DUPLICATE of bug 131441
Alias: None
Product: Fedora
Classification: Fedora
Component: module-init-tools   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-03 02:45 UTC by Daniel Linder
Modified: 2014-03-17 02:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Linder 2004-09-03 02:45:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
Did a "yum upgrade" and rebooted.  When system came up using the
modprobe or insmod commands from the 3.1-0.pre5 module-init-tools
package would result in a "segfault".  Finding the previous
"module-init-tools-3.0-2.i386.rpm" and doing an "rpm -Uvh --oldpackage
module-init-tools-3.0-2.i386.rpm" fixed the problem.

MD5SUM of new package:
7fcf51e0b8c8ae71209bcf5b25bdf95b module-init-tools-3.1-0.pre5.1.i386.rpm

I also verified that the "pre5" packaged had installed correctly by
running "rpm -vV module-init-tools-3.1-0.pre5.1" and the components
came back as correct.

Version-Release number of selected component (if applicable):
module-init-tools-3.1-0.pre5.1

How reproducible:
Didn't try

Steps to Reproduce:
1. Unknown.  Possibly install module-init-tools-3.1-0.pre5 RPM...?
2.
3.
    

Actual Results:  sedfault whenever a "modprobe" or "insmod" is issued.
 Other programs in the package such as "lsmod" appear to work fine.

Expected Results:  Module should have been inserted.

Additional info:

Comment 1 Daniel Linder 2004-09-03 03:10:29 UTC
Here is a script captured showing the failure is reproducable:
## Show kernel version
Linux localhost.localdomain 2.6.8-1.538smp #1 SMP Tue Aug 31 16:28:45
EDT 2004 i686 i686 i386 GNU/Linux

## Old 3.0 module-init-tools
> rpm -qf /sbin/modprobe
module-init-tools-3.0-2
> lsmod | grep usbserial
usbserial              26025  0
> rmmod usbserial
> modprobe usbserial
> lsmod | grep usbserial
usbserial              26025  0
> rmmod usbserial

## New 3.1-0.pre5 module-init-tools
> rpm -Uvh
/var/cache/yum/development/packages/module-init-tools-3.1-0.pre5.1.i386.rpm
Preparing...               
########################################### [100%]
   1:module-init-tools     
########################################### [100%]

### HERE BEGINS THE FAILURE!!! ###
> modprobe usbserial
# default modutils aliases
alias binfmt-204 binfmt_aout
/tmp/modscript: line 23:  4792 Segmentation fault      modprobe usbserial
### END FAILURE ###

## Show that the RPM installed correctly
> rpm -vV module-init-tools
.........   /etc/modprobe.conf.dist
.........   /sbin/depmod
.........   /sbin/generate-modprobe.conf
.........   /sbin/insmod
.........   /sbin/insmod.static
.........   /sbin/lsmod
.........   /sbin/modinfo
.........   /sbin/modprobe
.........   /sbin/rmmod
......... d /usr/share/man/man5/modprobe.conf.5.gz
......... d /usr/share/man/man5/modules.dep.5.gz
......... d /usr/share/man/man8/depmod.8.gz
......... d /usr/share/man/man8/insmod.8.gz
......... d /usr/share/man/man8/lsmod.8.gz
......... d /usr/share/man/man8/modinfo.8.gz
......... d /usr/share/man/man8/modprobe.8.gz
......... d /usr/share/man/man8/rmmod.8.gz

## Re-install the old version...
> rpm -Uvh --oldpackage
/var/cache/yum/development/packages/module-init-tools-3.0-2.i386.rpm
Preparing...               
########################################### [100%]
   1:module-init-tools     
########################################### [100%]
> lsmod | grep usbserial
## Note nothing loaded using the 3.1-0.pre5 modules.
> modprobe usbserial
> lsmod | grep usbserial
usbserial              26025  0


Comment 2 Zack Cerza 2004-09-03 03:35:17 UTC

*** This bug has been marked as a duplicate of 131441 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:05:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.