Bug 1316972 - glibc: NULL pointer dereference in stub resolver with unconnectable name server addresses
glibc: NULL pointer dereference in stub resolver with unconnectable name serv...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Florian Weimer
Fedora Extras Quality Assurance
:
: 1331711 (view as bug list)
Depends On:
Blocks: 1320596 1320599 1323839
  Show dependency treegraph
 
Reported: 2016-03-11 10:16 EST by Florian Weimer
Modified: 2016-06-16 05:16 EDT (History)
11 users (show)

See Also:
Fixed In Version: glibc-2.22-15.fc23, glibc-2.23.1-7.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1320596 1320599 (view as bug list)
Environment:
Last Closed: 2016-05-15 00:53:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 19791 None None None 2016-03-11 10:16 EST
Sourceware 19825 None None None 2016-03-23 11:22 EDT

  None (edit)
Description Florian Weimer 2016-03-11 10:16:32 EST
If /etc/resolv.conf contains addresses which cause the connect system call to fail immediately, queries which trigger search along the search path result in a segmentation fault.

A workaround is to remove the problematic addresses from /etc/resolv.conf.
Comment 1 Florian Weimer 2016-03-23 11:22:08 EDT
swbz#19825 is a very similar bug in send_vc/TCP (the original bug is about send_dg/UDP), so far only observed under valgrind.

swbz#19831 and swbz#19830 should be backported as well, to get cleaner test suite runs.
Comment 2 Florian Weimer 2016-04-29 08:05:21 EDT
*** Bug 1331711 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2016-05-07 13:18:39 EDT
glibc-2.22-15.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-68abc0be35
Comment 4 Fedora Update System 2016-05-08 12:24:58 EDT
glibc-2.22-15.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-68abc0be35
Comment 5 Florian Weimer 2016-05-09 05:41:01 EDT
Pre-existing 2.23 backport:

commit 3a188eb4e641d2df0cfd352fd09232347f28fbe1
Author: Florian Weimer <fweimer@redhat.com>
Date:   Fri Mar 25 11:49:51 2016 +0100

    resolv: Always set *resplen2 out parameter in send_dg [BZ #19791]

New backport:

commit 075b2665b159491fdd17f5aee90d47fa7388ed6f
Author: Florian Weimer <fweimer@redhat.com>
Date:   Wed Apr 27 14:26:47 2016 +0200

    resolv: Always set *resplen2 out parameter in send_vc [BZ #19825]
    
    In various error scenarios (for example, if the server closes the
    TCP connection before sending the full response), send_vc can return
    without resetting the *resplen2 value.  This can pass uninitialized
    or unexpected data to the caller.
    
    (cherry picked from commit b9bdfa7c8fa22c944bb5f21a673dfd1f91b71c56)
Comment 6 Fedora Update System 2016-05-09 10:56:33 EDT
glibc-2.23.1-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b321728d74
Comment 7 Fedora Update System 2016-05-10 13:57:06 EDT
glibc-2.22-15.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2016-05-10 16:30:01 EDT
glibc-2.23.1-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b321728d74
Comment 9 Fedora Update System 2016-05-11 09:54:53 EDT
glibc-2.23.1-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b321728d74
Comment 10 Fedora Update System 2016-05-12 05:43:57 EDT
glibc-2.23.1-7.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b321728d74
Comment 11 Fedora Update System 2016-05-14 19:29:53 EDT
glibc-2.23.1-7.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.