Bug 1317076 - Ruby 2.2.2p95 as delivered by rh-ruby22 SCL suffers from Ruby bug #10933
Ruby 2.2.2p95 as delivered by rh-ruby22 SCL suffers from Ruby bug #10933
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: ruby (Show other bugs)
rh-ruby22
x86_64 Linux
high Severity high
: alpha
: 2.2
Assigned To: Jun Aruga
Iveta Wiedermann
:
Depends On: 1348918
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 16:47 EST by Scott Merrill
Modified: 2016-07-25 04:48 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Object allocation is forbidden during the garbage collection phase of Ruby. Previously, the global symbol hash table used comparison by key values, which could allocate a new object during the garbage collection phase. This consequently led to termination of the Ruby process. With this update, the global symbol hash table uses key comparison by identity instead, which does not allocate an additional object. As a result, no additional objects are allocated during the garbage collection phase.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-25 04:48:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
briang: needinfo+


Attachments (Terms of Use)
Ruby bug 10933 stack trace (351.65 KB, text/plain)
2016-03-11 16:47 EST, Scott Merrill
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Ruby 10933 None None None 2016-03-11 16:47 EST

  None (edit)
Description Scott Merrill 2016-03-11 16:47:40 EST
Created attachment 1135418 [details]
Ruby bug 10933 stack trace

Description of problem: Ruby 2.2.2p95 as delivered by rh-ruby22 SCL suffers from Ruby bug #10933

https://bugs.ruby-lang.org/issues/10933
https://bugs.ruby-lang.org/issues/10968
https://bugs.ruby-lang.org/projects/backport22/repository/revisions/50493

Version-Release number of selected component (if applicable):
$ scl enable rh-ruby22 -- ruby --version
ruby 2.2.2p95 (2015-04-13 revision 50295) [x86_64-linux-gnu]
$ sudo yum info rh-ruby22
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
Available Packages
Name        : rh-ruby22
Arch        : x86_64
Version     : 2.0
Release     : 6.el6
Size        : 4.5 k
Repo        : rhel-x86_64-server-6-rhscl-1
Summary     : Package that installs rh-ruby22
License     : GPLv2+
Description : This is the main package for rh-ruby22 Software Collection.



Additional info:
We're testing Ruby 2.2 in our CI environment, and are running into this Ruby bug.  Stacktrace from CI attached.

It looks like it's fixed upstream on 2015-05-14 and the fix is in Ruby 2.2.3, as well as in a later patch release of 2.2.2.

Can SCL rh-ruby22 get updated to resolve this problem?

I see "rh-ruby23" as a version of SCL here in Bugzilla: what's the release date on that?
Comment 1 Vít Ondruch 2016-03-14 07:56:38 EDT
Hi Scott,

Thank you for your report and please see few comments inline.


(In reply to Scott Merrill from comment #0)
> Description of problem: Ruby 2.2.2p95 as delivered by rh-ruby22 SCL suffers
> from Ruby bug #10933

Did you have chance to test Ruby 2.2.2 with the patch from the bug you are referring applied or have you tried it with more recent version of Ruby to confirm it is definitely the same bug?

I am asking since in my experience, the similar bug might have different reasons.

> Can SCL rh-ruby22 get updated to resolve this problem?

There is actually bug 1280296 asking for Ruby update. Unfortunately, I can't promise anything. However, you might try to open ticket with our support, to escalate this.

> I see "rh-ruby23" as a version of SCL here in Bugzilla: what's the release
> date on that?

I can't give timelines here yet I'm afraid, so stock answer: Ruby 2.3 is 
being evaluated for inclusion in a future update to Red Hat Software 
Collections.
Comment 2 Joe Orton 2016-03-14 08:29:42 EDT
Scott, if you have issues which affect production deployments of RHSCL collections it helps us if you can file a ticket with Red Hat Support so we can track and prioritize requests based on the business impact.
Comment 3 Scott Merrill 2016-03-14 10:02:23 EDT
(In reply to Vít Ondruch from comment #1)
> Did you have chance to test Ruby 2.2.2 with the patch from the bug you are
> referring applied or have you tried it with more recent version of Ruby to
> confirm it is definitely the same bug?
> 
> I am asking since in my experience, the similar bug might have different
> reasons.

We have not rebuilt the rh-ruby22 SCL RPM to include this patch.

We do not have our CI implementation configured to use anything other than Red Hat RPMs, so we're not in a good position to test arbitrary Ruby versions on RHEL hosts.

If needed, we could manually install a newer version of Ruby and try to exercise the tests.  Would that help drive a resolution to this issue?
Comment 4 Scott Merrill 2016-03-14 10:12:22 EDT
(In reply to Joe Orton from comment #2)
> Scott, if you have issues which affect production deployments of RHSCL
> collections it helps us if you can file a ticket with Red Hat Support so we
> can track and prioritize requests based on the business impact.

Case #01600217 opened at access.redhat.com
Comment 19 Brian Gollaher 2016-05-16 15:25:50 EDT
Let's fix the bug with a z-stream fix to ruby22.

Brian
Comment 20 Honza Horak 2016-06-06 09:29:42 EDT
We're after GA, so changing rhscl-2.1.z to rhscl-2.2.z.
Comment 39 errata-xmlrpc 2016-07-25 04:48:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1482.html

Note You need to log in before you can comment on or make changes to this bug.