Bug 131708 - ImageMagick convert missing file
Summary: ImageMagick convert missing file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ImageMagick
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
: 132007 (view as bug list)
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-09-03 13:41 UTC by Sammy
Modified: 2013-04-02 04:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-15 19:06:44 UTC


Attachments (Terms of Use)
spec file (17.29 KB, text/plain)
2004-09-03 13:43 UTC, Sammy
no flags Details
ImageMagick spec diff file (925 bytes, patch)
2004-09-07 04:08 UTC, Mamoru TASAKA
no flags Details | Diff

Description Sammy 2004-09-03 13:41:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; X11; en_US, en_US.UTF-8, en) (KHTML, like Gecko)

Description of problem:
when I try to convert a postscript file using convert i.e.

convert fig3.ps f.eps

I get an error:

convert: UnableToOpenConfigureFile.
convert: missing an image filename `f.eps'.

some config file or perhaps some delagate is not where it is
supposed to be.

I have been building my 6.0.6 rpms for a long time and they are
working fine. I am attaching my spec file (may not be perfect!)

Version-Release number of selected component (if applicable):
ImageMagick-6.0.6.2

How reproducible:
Always

Steps to Reproduce:
1. upgrade to 6.0.6.2
2. use convert to convert a file
3.
    

Additional info:

Comment 1 Sammy 2004-09-03 13:43:30 UTC
Created attachment 103434 [details]
spec file

Comment 2 Daniel Malmgren 2004-09-03 17:20:32 UTC
This is not just convert. I get this from all ImageMagick tools since
last update (6.0.6.2-1, updating from 5.5.7.15-1.3).

Comment 3 Sammy 2004-09-05 18:16:58 UTC
While at it we should go to 6.0.7-1 stable since it fixes a few other problems. 

Comment 4 Mamoru TASAKA 2004-09-06 03:18:17 UTC
According to imagemagick.org, convert and other commands search 
for 2 configuration files. 
When I linked /usr/share/ImageMagick-6.0.6
to existing /usr/share/ImageMagick directory,
convert command seems to work well.


Comment 5 Tim Waugh 2004-09-06 13:52:32 UTC
So the question is: should ImageMagick be looking in
/usr/share/ImageMagick-6.0.6/ or /usr/share/ImageMagick/?

Comment 6 Mamoru TASAKA 2004-09-07 04:08:39 UTC
Created attachment 103527 [details]
ImageMagick spec diff file

Comment 7 Mamoru TASAKA 2004-09-07 04:12:18 UTC
I found that /usr/lib/ImageMagick-6.0.6/config directory 
( which is included in rpm ) is also the search path of convert etc. , 
and almost all .mgk file are already in the directory.

So, moving all .mgk files in /usr/share/ImageMagick 
directory to that directory will meet the demand. 
I made the diff file for spec file (which I previously sent.. sorry)
which seems to work for me.

Comment 8 taj 2004-09-08 23:22:46 UTC

This is related to 132007.  I was going to mark it a duplicate of this
bug.  But Momoru's comment (#7) is contradictory to what I saw. 
Perhaps he is mistaken.

rpm -qli ImageMagick |grep conf && rpm -q ImageMagick
/usr/bin/Wand-config
/usr/lib64/ImageMagick-6.0.6/config
/usr/lib64/ImageMagick-6.0.6/config/colors.mgk
/usr/lib64/ImageMagick-6.0.6/config/configure.mgk
/usr/lib64/ImageMagick-6.0.6/config/delegates.mgk
/usr/lib64/ImageMagick-6.0.6/config/english.mgk
/usr/lib64/ImageMagick-6.0.6/config/locale.mgk
/usr/lib64/ImageMagick-6.0.6/config/type-ghostscript.mgk
/usr/lib64/ImageMagick-6.0.6/config/type-solaris.mgk
/usr/lib64/ImageMagick-6.0.6/config/type-windows.mgk
/usr/lib64/ImageMagick-6.0.6/config/type.mgk
/usr/share/ImageMagick/configure.mgk
/usr/share/man/man1/Magick++-config.1.gz
/usr/share/man/man1/Magick-config.1.gz
/usr/share/man/man1/Wand-config.1.gz

ImageMagick-6.0.6.2-1

The application is looking for usr/lib64/ImageMagick/* which looks
consistant with other packages.  Please make sure the RPM places the
file there instead of /usr/lib64/ImageMagick-6.0.6

With that, I'll mark 132007 a duplicate of this bug.  But I think
Mamoru mispoke.

More details in 132007


Comment 9 taj 2004-09-08 23:23:59 UTC
*** Bug 132007 has been marked as a duplicate of this bug. ***

Comment 10 Mamoru TASAKA 2004-09-09 04:24:25 UTC
I suppose that taj is using x86_64 package , where I am
using i386 package.  That seems to be the reason the directory
of library differ. I checked both rpm packages and those
directory differed.

Then, it may be more preferable that all the mgk file in 
/usr/share/ImageMagick directory to /usr/share/ImageMagick-6.0.6
directory rather than to /usr/lib*/ImageMagick-6.0.6/config
directory as taj previously commented.

The searching directory is also checked by the command:

convert -debug configure logo: image.pnm

which imagemagick.org introduces.


Comment 11 Dan Williams 2004-09-14 18:12:27 UTC
convert et al look for the files in:

/usr/share/ImageMagick/config/*

Current RPMs (ImageMagick.i386 0:6.0.6.2-2) are broken in this respect
because they link the *.mgk files into /usr/share/ImageMagick but not
into /usr/share/ImageMagick/config


Comment 12 Dan Williams 2004-09-14 18:29:32 UTC
Hmm, I lied, that doesn't fix it...

Comment 13 Karsten Hopp 2004-09-15 19:06:44 UTC
ImageMagick-6.0.7.1-3 fixes the config file stuff.  
It just leaves an empty /usr/share/ImageMagick, this is fixed in CVS. 


Note You need to log in before you can comment on or make changes to this bug.