This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 132007 - ImageMagic /usr/share files in wrong directory, need version.
ImageMagic /usr/share files in wrong directory, need version.
Status: CLOSED DUPLICATE of bug 131708
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Mike McLean
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-07 15:38 EDT by taj
Modified: 2013-04-02 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description taj 2004-09-07 15:38:44 EDT
Description of problem:

package appears to be incomplete after upgrade

convert -verbose /dev/null  /dev/null
convert: UnableToOpenConfigureFile.
convert: missing an image filename `/dev/null'.


Version-Release number of selected component (if applicable):

ImageMagick-6.0.6.2-1

How reproducible:

100%

Steps to Reproduce:
convert -verbose /dev/null  /dev/null (or use valid image names)
  
Actual results:

UnableToOpenConfigureFile.

Expected results:

get past UnableToOpenConfigureFile.

Additional info:

strace  convert -verbose /dev/null  /dev/null 2>&1 |grep "No such"

open("/usr/lib64/ImageMagick-6.0.6/config/magic.mgk", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/ImageMagick-6.0.6/config/magic.mgk", O_RDONLY) = -1
ENOENT (No such file or directory)
open("/usr/share/ImageMagick-6.0.6/magic.mgk", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/root/.magick/magic.mgk", O_RDONLY) = -1 ENOENT (No such file or
directory)
open("magic.mgk", O_RDONLY)             = -1 ENOENT (No such file or
directory)

...

So..
 1185  cd /usr/share
 1186  ln -s ImageMagick/ ImageMagick-6.0.6
 1187   convert -verbose /dev/null /dev/null
Start of Image
Define Huffman Table 0x00
          0   1   5   1   1   1   1   1
          1   0   0   0   0   0   0   0
Define Huffman Table 0x01
          0   3   1   1   1   1   1   1
          1   1   1   0   0   0   0   0
Define Huffman Table 0x10
          0   2   1   3   3   2   4   3
          5   5   4   4   0   0   1 125
Define Huffman Table 0x11
          0   2   1   2   4   4   3   4
          7   5   4   4   0   1   2 119
End Of Image
convert: missing an image filename `/dev/null'.
Comment 1 taj 2004-09-08 19:23:47 EDT

*** This bug has been marked as a duplicate of 131708 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:31 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.