Bug 1317128 - RFE: Require option specify the IP address instead of interface during MON/OSD configure
RFE: Require option specify the IP address instead of interface during MON/OS...
Status: CLOSED ERRATA
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer (Show other bugs)
2
Unspecified Unspecified
unspecified Severity urgent
: ---
: 2
Assigned To: Alfredo Deza
Martin Kudlej
:
Depends On:
Blocks: 1291304
  Show dependency treegraph
 
Reported: 2016-03-12 03:54 EST by Nishanth Thomas
Modified: 2016-08-23 15:48 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:48:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nishanth Thomas 2016-03-12 03:54:35 EST
Description of problem:

Currently the APIs for configuring MON/OSD takes the network interface as input. Instead a provision to specify the IP address should be provided

As per the ceph documentation, there are two network interfaces to be configured - public network and cluster network - and how this is done currently by taking a single interface? same interface is used for both?
Comment 2 Andrew Schoen 2016-03-15 12:48:03 EDT
Until this is completed you'll need to look at the interfaces on the node to find the one that matches the IP address you'd like to use and provide that interface to ceph-installer.
Comment 3 Gregory Meno 2016-03-18 12:04:02 EDT
3-4 days effort in ceph-installer and ceph-ansible
Comment 4 Alfredo Deza 2016-03-24 15:47:08 EDT
ceph-ansible PR by Andrew Schoen: https://github.com/ceph/ceph-ansible/pull/643
ceph-installer PR https://github.com/ceph/ceph-installer/pull/126
docs PR https://github.com/ceph/ceph-installer/pull/127
Comment 5 Mike McCune 2016-03-28 18:11:59 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Gregory Meno 2016-04-05 00:27:26 EDT
This is fixed in ceph-installer 1.0.2 right?
Comment 7 Andrew Schoen 2016-04-05 10:16:00 EDT
(In reply to Gregory Meno from comment #6)
> This is fixed in ceph-installer 1.0.2 right?

Yes, this feature is in 1.0.2 of ceph-installer and ceph-ansible.
Comment 16 errata-xmlrpc 2016-08-23 15:48:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754

Note You need to log in before you can comment on or make changes to this bug.