Bug 131713 - ps output from libgnomeprint22 (abiword/gnumeric) with Thorndale contains boxes
Summary: ps output from libgnomeprint22 (abiword/gnumeric) with Thorndale contains boxes
Status: CLOSED DUPLICATE of bug 131222
Alias: None
Product: Fedora
Classification: Fedora
Component: libgnomeprint22   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-03 14:22 UTC by Bill Nottingham
Modified: 2014-03-17 02:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 16:13:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the postscript output (390.66 KB, application/octet-stream)
2004-09-06 20:53 UTC, Bill Nottingham
no flags Details
on my rawhide (817.74 KB, application/postscript)
2004-09-07 10:11 UTC, Caolan McNamara
no flags Details
openoffice source doc which is ok (5.29 KB, application/vnd.sun.xml.writer)
2004-09-28 08:17 UTC, Caolan McNamara
no flags Details
abiword source document which is not (23.81 KB, application/x-abiword)
2004-09-28 08:18 UTC, Caolan McNamara
no flags Details
gnumeric source document which is not (1.71 KB, text/plain)
2004-09-28 08:19 UTC, Caolan McNamara
no flags Details
ok output from openoffice.org (33.14 KB, application/postscript)
2004-09-28 08:20 UTC, Caolan McNamara
no flags Details
output from abiword (51.75 KB, application/postscript)
2004-09-28 08:21 UTC, Caolan McNamara
no flags Details
output from gnumeric (129.59 KB, application/postscript)
2004-09-28 08:22 UTC, Caolan McNamara
no flags Details

Description Bill Nottingham 2004-09-03 14:22:54 UTC
Printing http://devserv.devel.redhat.com/~notting/foo.doc

yields boxes throughout most of the text. The document displays fine.

Comment 1 Caolan McNamara 2004-09-06 14:42:12 UTC
Can you attach the output from postscript printing to file as well,
and mention if that's fubared in ggv

Comment 2 Bill Nottingham 2004-09-06 20:53:10 UTC
Created attachment 103516 [details]
the postscript output

Here it is, and yes, it's fubar.

Comment 3 Caolan McNamara 2004-09-07 10:11:45 UTC
Created attachment 103532 [details]
on my rawhide

That's a real nuisance, my print to file output is fine with abiword 2.0.11 and
libgnomeprint22-2.7.1 etc :-(

Comment 4 Bill Nottingham 2004-09-07 14:01:55 UTC
OK, I've got abiword-2.0.11-1 and libgnomeprint22-2.7.1-5. I'm
presuming you're running in UTF-8, etc.

Comment 5 Michael Knepher 2004-09-20 18:48:00 UTC
I have the same issue printing from other applications (such as gedit,
glabels) using certain fonts (Bitstream, Lucida, etc.). Some fonts
(including the MS fonts and the Luxi family) work fine. Printing to
PDF also seems to work fine, regardless of font.

Comment 6 Caolan McNamara 2004-09-27 11:42:12 UTC
Printing bugs are frustrating when I can't reproduce the problem...
for the record I'm now stock unmodified rawhide with locale
en_IE.UTF-8, abiword 2.0.11-3, libgnomeprint22-2.7.1-7 and no problems
with this document

Comment 7 Bill Nottingham 2004-09-27 15:55:17 UTC
Looking at the diff of the generated postscript:

--- output.ps   2004-09-27 11:57:20.083396656 -0400
+++ output.mine.ps      2004-09-27 11:57:26.408587126 -0400
@@ -9,12 +9,10 @@
 %%PageOrder: Ascend
 %%Title:
 %%DocumentSuppliedResources: procset pnome-print-procs-2.7.1
-%%+ font (GnomeUni-ThorndaleAMT-Italic) cvn
-%%+ font (GnomeUni-ThorndaleAMT-Bold) cvn
+%%+ font (GnomeUni-NimbusRomNo9L-ReguItal) cvn
 %%+ font (GnomeUni-StandardSymL) cvn
-%%+ font (GnomeUni-ThorndaleAMT) cvn
-%%+ font (GnomeUni-ThorndaleAMT) cvn
-%%+ font (GnomeUni-ThorndaleAMT-Bold) cvn
+%%+ font (GnomeUni-NimbusRomanNo9L-Regu) cvn
+%%+ font (GnomeUni-NimbusRomNo9L-Medi) cvn
 %%Requirements: numcopies(1) duplex
 %%EndComments
 %%BeginDefaults

(other stuff snipped)

Somehow, I suspect that that's the problem.

Comment 8 Caolan McNamara 2004-09-28 07:41:39 UTC
Yes with fonts-monotype installed its reproducable. Excellent.

Comment 9 Caolan McNamara 2004-09-28 08:17:20 UTC
Created attachment 104415 [details]
openoffice source doc which is ok

Comment 10 Caolan McNamara 2004-09-28 08:18:25 UTC
Created attachment 104416 [details]
abiword source document which is not

Comment 11 Caolan McNamara 2004-09-28 08:19:10 UTC
Created attachment 104417 [details]
gnumeric source document which is not

Comment 12 Caolan McNamara 2004-09-28 08:20:29 UTC
Created attachment 104418 [details]
ok output from openoffice.org

Comment 13 Caolan McNamara 2004-09-28 08:21:32 UTC
Created attachment 104419 [details]
output from abiword

Comment 14 Caolan McNamara 2004-09-28 08:22:10 UTC
Created attachment 104420 [details]
output from gnumeric

Comment 15 Caolan McNamara 2004-09-28 08:26:51 UTC
So three applications, the two gnome ones using libgnomeprint22 have
odd postscript output with boxes when using Thorndale from
fonts-monotype when a line of 11 point Thorndale is followed by a line
of 10 point Thorndale. While openoffice.org has expected output
without boxes.

caolan->owen: Looks like something happening at a gnomeprint22 or
lower layer than gnumeric/abiword are aware of.

Comment 16 Owen Taylor 2004-09-28 15:34:43 UTC
Please reopen if it still occurs with 2.8.0.


*** This bug has been marked as a duplicate of 131222 ***

Comment 17 Caolan McNamara 2004-09-28 16:13:41 UTC
Yep, that does the trick. Nice and correct with libgnomeprint22 2.8.0-1


Note You need to log in before you can comment on or make changes to this bug.