Bug 131222 - gnomeprint does not embed glyphs for indic postscript on some font sizes
gnomeprint does not embed glyphs for indic postscript on some font sizes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgnomeprint22 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
: i18n
: 131713 133315 133747 (view as bug list)
Depends On:
Blocks: Indic
  Show dependency treegraph
 
Reported: 2004-08-30 01:55 EDT by Leon Ho
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 15:12:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pdf output (54.65 KB, application/octet-stream)
2004-08-30 03:25 EDT, Leon Ho
no flags Details
same document, but postscript output (108.46 KB, application/postscript)
2004-08-30 03:26 EDT, Leon Ho
no flags Details
screenshot of ggv (59.26 KB, image/png)
2004-08-30 05:05 EDT, Leon Ho
no flags Details
What I get (93.07 KB, application/postscript)
2004-08-30 15:20 EDT, Owen Taylor
no flags Details

  None (edit)
Description Leon Ho 2004-08-30 01:55:53 EDT
Description of problem:
When printing in gedit with hi_IN.UTF-8, I encounter the postscript
did not have any glyphs whereas pdf output is okay.

Version-Release number of selected component (if applicable):
libgnomeprint22-2.7.1-3

How reproducible:


Steps to Reproduce:
1. Install Shree hi font
2. LANG=hi_IN.UTF-8 gedit
3. cut and paste some liguature at
http://bob.brisbane.redhat.com/eng/indic/hindi/BrowserTest_Hindi.html
4a. File -> Print -> Postscript -> File
or 
4b. File -> Print -> PDF -> File

5a. ggv output.ps
or
5b. ggv output.pdf

Actual results:
- PDF file is okay and print okay
- PS file shows sqaures on dev characters

Expected results:
- Both PS and PDF file is okay and print okay

Additional info:
Comment 1 Leon Ho 2004-08-30 03:25:47 EDT
Created attachment 103233 [details]
pdf output
Comment 2 Leon Ho 2004-08-30 03:26:49 EDT
Created attachment 103235 [details]
same document, but postscript output
Comment 3 Leon Ho 2004-08-30 03:29:23 EDT
also happens with rawhide20040828 fresh installation + the steps above.
Comment 4 Leon Ho 2004-08-30 05:05:20 EDT
Created attachment 103236 [details]
screenshot of ggv
Comment 6 Owen Taylor 2004-08-30 15:20:49 EDT
Created attachment 103264 [details]
What I get
Comment 7 Owen Taylor 2004-08-30 15:24:24 EDT
I can't reproduce this :-((  Can you check that you get the
same problem if you select the font explicitely in the "Page Setup
dialog? (I have other Hindi fonts on this system, so had to do
that)
Comment 8 Leon Ho 2004-08-30 21:41:24 EDT
There is a case for it to work or not.

By using SHREE-DV0701-OT font:
- If the size of the font is < 11 (i.e. the default print font and
size - Monospace 9), postscript will not print out properly.
- If the size of the font is >= 11, it will be okay.

It seems doesn't matter if I explictly choose the font or not.
Comment 9 Leon Ho 2004-08-30 21:50:50 EDT
new info: if I changed the headers font by default from Sans 11 to
Sans 9, then Monospace 9 will able to print out on the body.

So here is the new steps of reproduce:
[not working]
- install SHREE-DV0701-OT font
- File -> Page Setup -> Fonts -> Restore Default Fonts (so that the
Body is size 9; Headers and footers is size 11)
- Change the font only
- Print Postscript

[working]
- install SHREE-DV0701-OT font
- File -> Page Setup -> Fonts -> Change Headers and footer to size 9
(so both Body & Headers and footers are size 9)
- Print Postscript
Comment 10 Owen Taylor 2004-08-31 13:59:28 EDT
Still can't reproduce.

Not really sure where to go from here; debugging is likely going
to be rather difficult for me or anyone else, even with reproduction.
But maybe it's something more obvious if someone who can reproduce
it stepped into the code... most of the font embedding code is
a new contribution from Sun so I'm not familiar with it.
Comment 11 Leon Ho 2004-09-06 03:56:17 EDT
Well, i realised your header is in english. Are you using
LANG=en_US.UTF-8 gedit? I cannot reproduce this too if the header is
english. However if the header is in Hindi (i.e. LANG=hi_IN.UTF-8
gedit) then it shows the problem.

I agree, the code in gnome-print-ps2.c & libgnomeprint/ttsubset/* are
quite overwhelm. I will post to upstream and will hear what they say.
Comment 13 Owen Taylor 2004-09-06 22:58:54 EDT
I actually tested in hi_IN as well, couldn't reproduce there either.
Comment 14 Leon Ho 2004-09-12 22:23:14 EDT
Latest upstream cvs head fixes the problem. We will include it when
gnome releases right?
Comment 15 Owen Taylor 2004-09-13 15:10:21 EDT
Likely, yes. Relevant ChangeLog entry would be useful in making
sure that it actually gets in.
Comment 16 Owen Taylor 2004-09-27 14:29:45 EDT
*** Bug 133315 has been marked as a duplicate of this bug. ***
Comment 17 Owen Taylor 2004-09-27 14:30:17 EDT
*** Bug 133747 has been marked as a duplicate of this bug. ***
Comment 18 Owen Taylor 2004-09-27 15:12:05 EDT
ChangeLog entry and bug reference from upstream:

2004-08-10  Suresh Chandrasekharan <suresh.chandrasekharan@sun.com>
                                                                     
                                  
        Fix for #148674
                                                                     
                                  
        * libgnomeprint/gnome-print-ps2.c
        (gnome_print_ps2_set_font_real): Fixed incorrect subfont
comparison
        which created a duplicate entry for the same font with
different size
        in ps2->fonts.

libgnomeprint-2.8.0 is in Raw Hide, works for me.
Comment 19 Owen Taylor 2004-09-28 11:34:58 EDT
*** Bug 131713 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.