Bug 1317145 - xorg-x11-server 1.18.2 freezes machine
xorg-x11-server 1.18.2 freezes machine
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 1321058 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-12 09:10 EST by Harald Reindl
Modified: 2016-04-06 13:20 EDT (History)
10 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.18.3-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-06 13:20:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 94515 None None None 2016-03-20 08:16 EDT

  None (edit)
Description Harald Reindl 2016-03-12 09:10:40 EST
* full updated F23
* xorg-x11-drv-intel-2.99.917-19.20151206.fc23.x86_64
* short after login into KDE (restarted sddm) freeze
* CTRL+ALT+Fn -> no reaction -> no VT
* music player daemon in background loops
* power button happily shutdown the system clean
* tried again after boot -> freeze before all my apps where running
* power down again, downgrade before graphical login
* all is fine again

[root@srv-rhsoft:~]$ cat /etc/X11/xorg.conf.d/03-intel.conf
Section "Device"
 Identifier "Videocard0"
 Option     "AccelMethod" "sna"
 Option     "TearFree"    "true"
 Option     "DRI"         "3"
EndSection

Mar 12 14:45:21 INFO Upgraded: xorg-x11-server-common-1.18.2-1.fc23.x86_64
Mar 12 14:45:22 INFO Upgraded: xorg-x11-server-Xorg-1.18.2-1.fc23.x86_64
Mar 12 15:01:43 INFO Downgraded: xorg-x11-server-common-1.18.1-3.fc23.x86_64
Mar 12 15:01:44 INFO Downgraded: xorg-x11-server-Xorg-1.18.1-3.fc23.x86_64
Mar 12 15:01:44 INFO Erased: xorg-x11-server-Xorg-1.18.2-1.fc23.x86_64
Mar 12 15:01:44 INFO Erased: xorg-x11-server-common-1.18.2-1.fc23.x86_64

[root@srv-rhsoft:~]$ lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev a4)
00:1f.0 ISA bridge: Intel Corporation Q77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 Ethernet controller: Intel Corporation 82580 Gigabit Network Connection (rev 01)
01:00.1 Ethernet controller: Intel Corporation 82580 Gigabit Network Connection (rev 01)
01:00.2 Ethernet controller: Intel Corporation 82580 Gigabit Network Connection (rev 01)
01:00.3 Ethernet controller: Intel Corporation 82580 Gigabit Network Connection (rev 01)
02:00.0 Network controller: Qualcomm Atheros AR5418 Wireless Network Adapter [AR5008E 802.11(a)bgn] (PCI-Express) (rev 01)
Comment 1 Jaroslav Reznik 2016-03-17 05:57:03 EDT
Freezes my system right after SDDM starts.

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)

rpm -q xorg-x11-drv-intel
xorg-x11-drv-intel-2.99.917-19.20151206.fc23.x86_64

Happens on both 4.4.5 and 4.5 kernels.
Comment 2 Harald Reindl 2016-03-17 06:05:33 EDT
GREAT that there was no chance to give negative karma with "fedora-easy-karma" because yesterday (long after my bugreport) the package was pushed to updates-testing and 10 minutes later to updates-stable (according to bodhi)

this is a completly broken testing process 4 days after build get packages pushed to updates-testing - no serious tester is using the bodhi-homepage and seeking for packages when "fedora-easy-karma" only asks fro packages you *really* have instaleld which is very important in case of quick fixes followed by rebuilds where only the release-tag is raised
Comment 3 Jaroslav Reznik 2016-03-17 06:35:08 EDT
As Kamil mentioned in Bodhi, this really seems to be related to Qt 5/KF 5 bits as sddm, plasma and lxqt all freezes for me, gnome shell using gdm works. But it can still affect a lot of Qt desktop users.
Comment 4 Fedora Update System 2016-03-17 10:54:58 EDT
xorg-x11-server-1.18.2-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-72cfccf08b
Comment 5 Fedora Update System 2016-03-17 10:56:23 EDT
xorg-x11-server-1.18.2-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ec12a9fe2f
Comment 6 Harald Reindl 2016-03-17 14:18:11 EDT
AND HOW is xorg-x11-server-1.18.2-2.fc23 supposed to fix that bug?

while nothing in the changelog, downloaded it from koji in good faith, first login -> at the begin of init KDE freeze, disk activity starts, a few secods later MPD music stutters, heavy disk-IO which stinks like swapping, it takes 5 minutes to shutdown the machine with acpid and power-button
Comment 7 Tomas Dolezal 2016-03-18 06:37:24 EDT
i also have hangs, they tend to stop after waiting for >40s, but they reoccur during session when interacting with KDE

i am using intel graphics:
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K1100M] (rev a1)
4.4.5-300.fc23.x86_64

no errors in Xorg.log
Comment 8 Fedora Update System 2016-03-18 10:56:52 EDT
xorg-x11-server-1.18.2-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-72cfccf08b
Comment 9 Harald Reindl 2016-03-18 11:07:32 EDT
xorg-x11-server-1.18.2-2.fc24 has been pushed to the Fedora 24 testing

why the hell with already negative karma?
users with updates-testing enbaled are thankful for such behavior...
Comment 10 Fedora Update System 2016-03-18 21:25:41 EDT
xorg-x11-server-1.18.2-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ec12a9fe2f
Comment 11 Gerald Cox 2016-03-19 10:08:02 EDT
Lockups when using KDE.  Not able to use keyboard... need to reboot to recover.
This was with the 1.18.2-2 update.  Backed out to 
xorg-x11-server-Xorg-1.18.1-3.fc23.x86_64
Comment 12 Sammy 2016-03-20 12:22:20 EDT
In the related bug https://bugzilla.redhat.com/show_bug.cgi?id=1317153
I attached the patch from the above external bug that fixes the problem.
Comment 13 Rex Dieter 2016-03-21 12:38:02 EDT
Thanks Sammy!
Comment 14 Rex Dieter 2016-03-24 11:01:55 EDT
*** Bug 1321058 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2016-04-05 14:45:36 EDT
xorg-x11-server-1.18.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cebdf579ca
Comment 16 Fedora Update System 2016-04-06 13:20:06 EDT
xorg-x11-server-1.18.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.