This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1317191 - [abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\u201c' in position 658: ordinal not in range(128)
[abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode c...
Status: CLOSED DUPLICATE of bug 1295090
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
low Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:36b1aaac08233aa86e78c25fc6d...
: EasyFix, i18n, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-12 17:22 EST by Craig Farless
Modified: 2016-08-01 06:50 EDT (History)
7 users (show)

See Also:
Fixed In Version: dnf-1.1.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-01 06:50:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (707.24 KB, text/plain)
2016-03-12 17:22 EST, Craig Farless
no flags Details
File: backtrace (1.95 KB, text/plain)
2016-03-12 17:22 EST, Craig Farless
no flags Details
File: dnf-makecache.log (47.31 KB, text/plain)
2016-03-12 17:22 EST, Craig Farless
no flags Details
File: environ (1.79 KB, text/plain)
2016-03-12 17:22 EST, Craig Farless
no flags Details

  None (edit)
Description Craig Farless 2016-03-12 17:22:48 EST
Description of problem:
Browsing Postinstaller

Version-Release number of selected component:
dnf-1.1.6-2.fc23

Additional info:
reporter:       libreport-2.6.4
cmdline:        /usr/bin/python3 /usr/bin/dnf repoquery -i freedoom2
executable:     /usr/bin/dnf
kernel:         4.4.4-301.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\u201c' in position 658: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1095, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/repoquery.py", line 405, in run
    print(pkg)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 44, in write
    self.stream.write(s)
UnicodeEncodeError: 'ascii' codec can't encode character '\u201c' in position 658: ordinal not in range(128)

Local variables in innermost frame:
s: 'Name        : freedoom2\nVersion     : 0.10.1\nRelease     : 1.fc23\nArchitecture: noarch\nSize        : 8474358\nLicense     : BSD\nSource RPM  : freedoom-0.10.1-1.fc23.src.rpm\nBuild Date  : 2016-01-29 15:46\nPackager    : Fedora Project\nURL         : https://freedoom.github.io/\nSummary     : Doom2 styled first person shooter game\nDescription :\nFreedoom: Phase 2 is a Doom2 styled first person shooter game using the\nDoom engine. Freedoom: Phase 2 has 32 levels in one long chapter,\nfeaturing extra monsters and a double-barrelled shotgun.\n\nThere is a massive back catalog, spanning over two decades, containing\nthousands of Doom levels and other modifications (“mods”) made by fans\nof the original Doom game. Freedoom aims to be compatible with these and\nallows most to be played without the original Doom datafiles.\nFreedoom: Phase 2 aims for compatibility with Doom II and Final Doom.\n'
self: <dnf.i18n.UnicodeStream object at 0x7fb707528240>
Comment 1 Craig Farless 2016-03-12 17:22:54 EST
Created attachment 1135701 [details]
File: _var_log_dnf.log
Comment 2 Craig Farless 2016-03-12 17:22:55 EST
Created attachment 1135702 [details]
File: backtrace
Comment 3 Craig Farless 2016-03-12 17:22:56 EST
Created attachment 1135703 [details]
File: dnf-makecache.log
Comment 4 Craig Farless 2016-03-12 17:22:57 EST
Created attachment 1135704 [details]
File: environ
Comment 5 Honza Silhan 2016-03-14 09:18:21 EDT
Craig, can you provide the link to that rpm package, please? Can you query that package via `rpm -q`?
Comment 6 Craig Farless 2016-03-18 17:57:54 EDT
-1.5-39.20160204git8102266.fc23.noarch
Comment 7 Craig Farless 2016-03-18 18:11:07 EDT
postinstallerf-1.5-39.20160204git8102266.fc23.noarch
Comment 8 Honza Silhan 2016-03-21 08:59:20 EDT
Thanks. We'll take a look. Giving this low priority as this is not official package from Fedora repo and could be built by strange ways.
Comment 9 Fedora Admin XMLRPC Client 2016-07-08 05:37:54 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Štěpán Smetana 2016-08-01 06:50:35 EDT
Works for me.
Should be fixed in dnf-1.1.9 (Take a look at this commit https://github.com/rpm-software-management/dnf/commit/93159e360f0b6150e598bba783e22ca113201a40)
In case reopen this bug.
Thanks

*** This bug has been marked as a duplicate of bug 1295090 ***

Note You need to log in before you can comment on or make changes to this bug.