Bug 1317245 - [abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\u201c' in position 53: ordinal not in range(128)
[abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode c...
Status: CLOSED DUPLICATE of bug 1279204
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:e507aa1f18ca854fdac9925c3dc...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 06:04 EDT by Artem
Modified: 2016-04-11 07:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-11 07:54:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (257.10 KB, text/plain)
2016-03-13 06:04 EDT, Artem
no flags Details
File: backtrace (1.36 KB, text/plain)
2016-03-13 06:04 EDT, Artem
no flags Details
File: dnf-makecache.log (273.73 KB, text/plain)
2016-03-13 06:04 EDT, Artem
no flags Details
File: environ (2.26 KB, text/plain)
2016-03-13 06:04 EDT, Artem
no flags Details
dnf.librepo.log (816.65 KB, text/plain)
2016-03-30 14:09 EDT, Artem
no flags Details
yum.repos (1.55 KB, application/x-gzip)
2016-04-04 14:45 EDT, Artem
no flags Details

  None (edit)
Description Artem 2016-03-13 06:04:00 EDT
Version-Release number of selected component:
dnf-1.1.5-1.fc23

Additional info:
reporter:       libreport-2.6.4
cmdline:        /usr/bin/python3 /bin/dnf search nodejs
executable:     /bin/dnf
kernel:         4.2.8-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\u201c' in position 53: ordinal not in range(128)

Traceback (most recent call last):
  File "/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1095, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/search.py", line 106, in run
    return self._search(extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/search.py", line 81, in _search
    args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 784, in matchcallback
    print(msg)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 44, in write
    self.stream.write(s)
UnicodeEncodeError: 'ascii' codec can't encode character '\u201c' in position 53: ordinal not in range(128)

Local variables in innermost frame:
self: <dnf.i18n.UnicodeStream object at 0x7fc20202bd68>
s: '\x1b[1mnodejs\x1b(B\x1b[m-es-to-primitive.noarch : ECMAScript “ToPrimitive” algorithm'
Comment 1 Artem 2016-03-13 06:04:07 EDT
Created attachment 1135846 [details]
File: _var_log_dnf.log
Comment 2 Artem 2016-03-13 06:04:08 EDT
Created attachment 1135847 [details]
File: backtrace
Comment 3 Artem 2016-03-13 06:04:11 EDT
Created attachment 1135848 [details]
File: dnf-makecache.log
Comment 4 Artem 2016-03-13 06:04:12 EDT
Created attachment 1135849 [details]
File: environ
Comment 5 Honza Silhan 2016-03-14 09:33:06 EDT
I am sorry but can't reproduce it. You even have LANG=C. Probably the `nodejs-es-to-primitive` was fixed and released again. IF you still experience this, please, reopen.
Comment 6 Artem 2016-03-16 16:11:56 EDT
Hi
I can still reproduce the bug with the latest updates

Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1095, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/search.py", line 106, in run
    return self._search(extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/search.py", line 81, in _search
    args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 784, in matchcallback
    print(msg)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 44, in write
    self.stream.write(s)
UnicodeEncodeError: 'ascii' codec can't encode character '\u201c' in position 53: ordinal not in range(128)
Comment 7 Michal Luscon 2016-03-29 09:17:37 EDT
Could you please upload somewhere your /var/cache/dnf/fedora* and /var/cache/dnf/updates* folders and attach your dnf.librepo.log to this bugreport?
Comment 8 Artem 2016-03-30 14:09 EDT
Created attachment 1141893 [details]
dnf.librepo.log
Comment 9 Artem 2016-03-30 14:44:06 EDT
uploading 172M archive of the /var/cache/dnf/{updates,fedora}* content is quite complicated. I have just recently executed dnf distro-sync, so it is the actual state.

Please provide me a patch with more debugging or whatever else you need and I will apply it
Comment 10 Honza Silhan 2016-04-04 07:27:32 EDT
Can you upload your content if /etc/yum.repos.d/ directory and then try again `dnf search nodejs --refresh` whether you can still reproduce it, please?
Comment 11 Artem 2016-04-04 14:45 EDT
Created attachment 1143413 [details]
yum.repos

Yes, I can still reproduce the bug
Comment 12 Jaroslav Mracek 2016-04-11 07:54:24 EDT

*** This bug has been marked as a duplicate of bug 1279204 ***

Note You need to log in before you can comment on or make changes to this bug.