Bug 1317279 - iscsi login fails in v3
iscsi login fails in v3
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
4.0.0
Unspecified Unspecified
urgent Severity urgent (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Juan Hernández
Pavel Stehlik
: AutomationBlocker
: 1317281 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 13:40 EDT by Nelly Credi
Modified: 2016-07-05 03:58 EDT (History)
3 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:58:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
juan.hernandez: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54706 master MERGED restapi: Add V3 action adapters 2016-03-14 07:49 EDT

  None (edit)
Description Nelly Credi 2016-03-13 13:40:35 EDT
Description of problem:
iscsi login results in HTTP500

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1 send request ovirt-engine/api/hosts/f4930d27-6eee-42a7-9c00-b769cd119535/iscsilogin with version: 3 
<action>
    <async>false</async>
    <grace_period>
        <expiry>10</expiry>
    </grace_period>
    <iscsi>
        <target>.....</target>
        <address>.......</address>
    </iscsi>
</action>


Actual results:
HTTP 500
<html><head><title>Error</title></head><body>Internal Server Error</body></html>


Expected results:
HTTP 200

Additional info:
This is working with version:4
Comment 1 Yaniv Kaul 2016-03-13 17:13:30 EDT
Engine and server log? (please always attach them)
Comment 2 Juan Hernández 2016-03-14 07:48:42 EDT
This is caused by missing V4 adapters for the "Action" type. The proposed patch fixes the issue.
Comment 3 Juan Hernández 2016-03-14 07:49:29 EDT
*** Bug 1317281 has been marked as a duplicate of this bug. ***
Comment 4 Nelly Credi 2016-03-28 07:57:54 EDT
this was already fixed removing the need info
Comment 5 Sandro Bonazzola 2016-07-05 03:58:04 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.