Bug 1317281 - Import disk as template in v3 fails with http 500
Import disk as template in v3 fails with http 500
Status: CLOSED DUPLICATE of bug 1317279
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
4.0.0
Unspecified Unspecified
urgent Severity urgent (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Juan Hernández
Pavel Stehlik
: AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 13:53 EDT by Nelly Credi
Modified: 2016-03-28 07:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 07:49:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
juan.hernandez: ovirt‑4.0.0?
rule-engine: planning_ack+
juan.hernandez: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54706 master MERGED restapi: Add V3 action adapters 2016-03-14 07:49 EDT

  None (edit)
Description Nelly Credi 2016-03-13 13:53:37 EDT
Description of problem:
Import disk as template in v3 fails with http 500

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.connect glance
2.try to import image as template with v3:
/ovirt-engine/api/storagedomains/b9f6c2a0-41de-4afb-a9aa-6c19fbbd4d4d/images/d7eafdaa-f5fd-48fa-991d-1c51b15a243d/import

body:
<action>
    <async>false</async>
    <grace_period>
        <expiry>10</expiry>
    </grace_period>
    <storage_domain>
        <name>nfs_2</name>
    </storage_domain>
    <cluster>
        <name>golden_env_mixed_1</name>
    </cluster>
    <template>
        <name>golden_mixed_virtio_template</name>
    </template>
    <import_as_template>true</import_as_template>
    <disk>
        <name>golden_mixed_virtio_template</name>
    </disk>
</action>
3.

Actual results:
HTTP 500

Expected results:
HTTP 200

Additional info:
It is working with v4
Comment 1 Yaniv Kaul 2016-03-13 17:13:58 EDT
Engine and server log? (please always attach them)
Comment 2 Juan Hernández 2016-03-13 17:30:36 EDT
I'm almost 100% sure that this is the same that bug 1317279, however I won't close it as duplicated yet. I will once I confirm it completely.
Comment 3 Juan Hernández 2016-03-14 07:47:41 EDT
This is caused by missing V4 adapters for the "Action" type. The proposed patch fixes the issue.
Comment 4 Juan Hernández 2016-03-14 07:49:29 EDT
As the root cause of this bug is the same that bug 1317279 I'm closing this as duplicate.

*** This bug has been marked as a duplicate of bug 1317279 ***
Comment 5 Nelly Credi 2016-03-28 07:58:03 EDT
this was already fixed removing the need info

Note You need to log in before you can comment on or make changes to this bug.