Bug 1317361 - Do not succeed mkdir without gfid-req
Do not succeed mkdir without gfid-req
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: posix (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks: 1321550 1332372
  Show dependency treegraph
 
Reported: 2016-03-14 02:15 EDT by Pranith Kumar K
Modified: 2016-06-16 10:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1321550 1332372 (view as bug list)
Environment:
Last Closed: 2016-06-16 10:00:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2016-03-14 02:15:41 EDT
Description of problem:
    Do not allow directory creations without gfids as it is a pain
    to fix the gfids. After the directories are created, operations
    on them fail anyway. So it is better to fail mkdir.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-03-14 02:16:36 EDT
REVIEW: http://review.gluster.org/13690 (storage/posix: Fail mkdir without gfid-req) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-03-14 03:18:26 EDT
REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2016-03-15 02:03:09 EDT
REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Vijay Bellur 2016-03-16 02:29:39 EDT
REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Vijay Bellur 2016-03-16 03:39:29 EDT
REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 6 Vijay Bellur 2016-03-16 09:36:09 EDT
REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#6) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 7 Vijay Bellur 2016-03-18 08:00:11 EDT
REVIEW: http://review.gluster.org/13776 (features/trash: wind mkdir with special pid) posted (#1) for review on master by Anoop C S (anoopcs@redhat.com)
Comment 8 Mike McCune 2016-03-28 18:23:05 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 9 Vijay Bellur 2016-04-17 04:26:30 EDT
REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#7) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 10 Vijay Bellur 2016-04-26 11:31:28 EDT
REVIEW: http://review.gluster.org/13776 (features/trash: wind mkdir with special pid) posted (#2) for review on master by Anoop C S (anoopcs@redhat.com)
Comment 11 Vijay Bellur 2016-04-27 08:41:23 EDT
REVIEW: http://review.gluster.org/13776 (features/trash: wind mkdir with special pid) posted (#3) for review on master by Jeff Darcy (jdarcy@redhat.com)
Comment 12 Vijay Bellur 2016-04-27 17:24:51 EDT
COMMIT: http://review.gluster.org/13776 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit b5cfe948cb3569f034da80ac97b5d2f028b3b0e5
Author: Anoop C S <anoopcs@redhat.com>
Date:   Fri Mar 18 10:32:09 2016 +0530

    features/trash: wind mkdir with special pid
    
    Recent changes done w.r.t handling of mkdir calls in posix translator
    resulted in crashing the brick process from trash translator. This was
    due to the changes made in posix translator to return EPERM for every
    mkdir calls without 'gfid-req' set in dictionary. In order to avoid
    gfid mismatches during directory creation from brick side trash
    translator does not set 'gfid-req'. This patch is to have an exemption
    for trash based on a special pid set for those mkdir calls originating
    from trash translator and to reset it in callback.
    
    This patch also includes a small optimization to the existing test case
    for trash feature.
    
    Change-Id: I59f084ac875e54342ecf2bffa6e43ebd84814153
    BUG: 1317361
    Signed-off-by: Anoop C S <anoopcs@redhat.com>
    Reviewed-on: http://review.gluster.org/13776
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 13 Vijay Bellur 2016-04-28 03:11:24 EDT
REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#8) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 14 Vijay Bellur 2016-04-28 07:32:39 EDT
REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#9) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 15 Vijay Bellur 2016-04-29 09:57:43 EDT
COMMIT: http://review.gluster.org/13690 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit b246b07896fefb261c9fb07f3f29f0d03b81b88d
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Mar 14 10:59:38 2016 +0530

    dht/afr/client/posix: Fail mkdir without gfid-req
    
    Do not allow directory creations without gfids as
    after the directories are created, operations
    on them fail anyway. So it is better to fail mkdir.
    
    BUG: 1317361
    Change-Id: I8f8e3b38bbded1960b7215bac0432500f7e78038
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13690
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 16 Niels de Vos 2016-06-16 10:00:28 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.