Bug 1321550 - Do not succeed mkdir without gfid-req
Summary: Do not succeed mkdir without gfid-req
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: core
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: RHGS 3.1.3
Assignee: Pranith Kumar K
QA Contact: krishnaram Karthick
URL:
Whiteboard:
Depends On: 1317361 1332372
Blocks: 1311817
TreeView+ depends on / blocked
 
Reported: 2016-03-28 11:10 UTC by Pranith Kumar K
Modified: 2016-09-17 14:41 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.9-4
Doc Type: Bug Fix
Doc Text:
Clone Of: 1317361
Environment:
Last Closed: 2016-06-23 05:14:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1240 0 normal SHIPPED_LIVE Red Hat Gluster Storage 3.1 Update 3 2016-06-23 08:51:28 UTC

Description Pranith Kumar K 2016-03-28 11:10:42 UTC
+++ This bug was initially created as a clone of Bug #1317361 +++

Description of problem:
    Do not allow directory creations without gfids as it is a pain
    to fix the gfids. After the directories are created, operations
    on them fail anyway. So it is better to fail mkdir.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-03-14 02:16:36 EDT ---

REVIEW: http://review.gluster.org/13690 (storage/posix: Fail mkdir without gfid-req) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-03-14 03:18:26 EDT ---

REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-03-15 02:03:09 EDT ---

REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-03-16 02:29:39 EDT ---

REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-03-16 03:39:29 EDT ---

REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-03-16 09:36:09 EDT ---

REVIEW: http://review.gluster.org/13690 (dht/afr/client/posix: Fail mkdir without gfid-req) posted (#6) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Vijay Bellur on 2016-03-18 08:00:11 EDT ---

REVIEW: http://review.gluster.org/13776 (features/trash: wind mkdir with special pid) posted (#1) for review on master by Anoop C S (anoopcs@redhat.com)

Comment 1 Anuradha 2016-03-28 11:19:27 UTC
Patch posted :
https://code.engineering.redhat.com/gerrit/#/c/69979/

Comment 3 Mike McCune 2016-03-28 23:19:36 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 9 krishnaram Karthick 2016-05-30 14:41:43 UTC
Moving this bug to verified based on comment 8, as the issue reported isn't seen during regression testing.

Comment 11 errata-xmlrpc 2016-06-23 05:14:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240


Note You need to log in before you can comment on or make changes to this bug.