Bug 131737 - Kernel Panic: insmod: error inserting '/lib/ext3.ko' kernel-2.6.8-1.541
Kernel Panic: insmod: error inserting '/lib/ext3.ko' kernel-2.6.8-1.541
Status: CLOSED DUPLICATE of bug 131498
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-03 15:21 EDT by Xander D Harkness
Modified: 2016-06-07 18:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xander D Harkness 2004-09-03 15:21:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
I have just upgraded to the latest development kernel and the computer
will not boot.  I get the following message:

Red Hat nash version 4.1.9 starting
insmod: error inserting '/lib/ext3.ko': -1 Unknown symbol in module
ERROR: /bin/insmod exited abnormally! 
    Reading all physical volumes. This may take a while
    Found volume group "root" using metadata type lvm2
    4 Logical volumes in volume group "root" now active
mount: error 19 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
Umount /initrd/dev failed: 2
kernel panic - not syncing: Attempted to kill init!

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.541

How reproducible:
Always

Steps to Reproduce:
1.Boot kernel kernel-2.6.8-1.541
2. Kernel Panic
3.
    

Actual Results:  Machine fails to boot with kernel panic

Expected Results:  The macine should boot normally as it does with
other kernels (except kernel-2.6.8-1.538, which breaks in a different way)

Additional info:

The boot partition is ext3 on a primary partition, the rest of the
system is ext3 on LVM

IBM T41 laptop:
lspci
00:00.0 Host bridge: Intel Corp. 82855PM Processor to I/O Controller
(rev 03)
00:01.0 PCI bridge: Intel Corp. 82855PM Processor to AGP Controller
(rev 03)
00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0
EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 01)
00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage
Controller (rev 01)
00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon
Mobility M7 LW [Radeon Mobility 7500]
02:00.0 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus
Controller (rev 01)
02:00.1 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus
Controller (rev 01)
02:01.0 Ethernet controller: Intel Corp. 82540EP Gigabit Ethernet
Controller (Mobile) (rev 03)
02:02.0 Network controller: AIRONET Wireless Communications Cisco
Aironet Wireless 802.11b

500M RAM
Comment 1 Bill Nottingham 2004-09-03 18:41:08 EDT
What version of gawk do you have installed?
Comment 2 Xander D Harkness 2004-09-04 04:52:23 EDT
I have version: gawk-3.1.4-1
Comment 3 Jeremy Katz 2004-09-07 00:14:28 EDT
Back down to the gawk that's in fedora devel now and it'll work.  The
new gawk is broken with some of the regexes used in mkinitrd.
Comment 4 Jeremy Katz 2004-09-07 00:15:52 EDT

*** This bug has been marked as a duplicate of 131498 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:05:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.