Bug 131498 - gawk 3.1.4 with dfa breaks some regexes
gawk 3.1.4 with dfa breaks some regexes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gawk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
:
: 131447 131737 132456 (view as bug list)
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-09-01 15:18 EDT by Jeremy Katz
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 06:19:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2004-09-01 15:18:12 EDT
With gawk-3.1.4-1, mkinitrd doesn't (reliably) find the jbd module as
a dependency of ext3.

Downgrading to 3.1.3-9 or setting GAWK_NO_DFA=1 works around.

For now, moved 3.1.4-1 out of dist-fc3 (to -scratch)
Comment 1 Thomas Woerner 2004-09-02 07:39:31 EDT
Oh nice, you moved my package?
Comment 4 Bill Nottingham 2004-09-02 15:59:45 EDT
*** Bug 131447 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2004-09-07 00:16:15 EDT
*** Bug 131737 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2004-09-13 13:09:48 EDT
*** Bug 132456 has been marked as a duplicate of this bug. ***
Comment 8 Eugene Kanter 2004-09-18 09:40:28 EDT
It clearly depends of the modules.dep size. If the file is small then
awk 3.1.4 works fine.
# grep ext3 modules.dep >m.dep
# ./awk -f test.awk m.dep ext3
 jbd
# ./awk -f test.awk modules.dep ext3

# ./awk --version | head -1
GNU Awk 3.1.4
# awk -f test.awk modules.dep ext3
 jbd
# awk --version | head -1
GNU Awk 3.1.3# wc modules.dep m.dep
  1051   2967 177910 modules.dep
     1      2     95 m.dep
Comment 10 Pekka Pietikäinen 2004-10-15 19:05:02 EDT
Debian seems to have the same bug filed with some commentary and a
possible fix (but yea, it's something that should probably be handled
upstream and a post-FC3 thing in any case)

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=266519
Comment 11 Karel Zak 2004-11-11 10:25:52 EST
This is bug in dfa.c, fixed by patch from Aharon Robbins. It will
fixed in FC4. The mkinitrd stuff was fixed and works with this path.
You can try test it with package and tests from:

http://people.redhat.com/kzak/gawk/
Comment 12 Karel Zak 2004-11-15 06:19:40 EST
Fixed in gawk-3.1.4-4 [FC-4].

Note You need to log in before you can comment on or make changes to this bug.