Bug 131747 - evolution menu item appears in Office and Internet
evolution menu item appears in Office and Internet
Status: CLOSED DUPLICATE of bug 125865
Product: Fedora
Classification: Fedora
Component: redhat-menus (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-03 17:02 EDT by Bryan W Clark
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan W Clark 2004-09-03 17:02:40 EDT
Evo should only appear once

The Email item in the Internet menu is the one we want.

The other one is bollocks.
Comment 1 Zack Cerza 2004-09-03 17:18:51 EDT
I agree with you in spirit, but this poses the question:

What if I want to use one of the other 5 mailers that are availible to
set as my default? Then $MAILER will have two menu items pointing to
it: its own item and the generic item. Evo will have zero menu items,
and the rest will have one*.

Note that I don't necessarily disagree with you, just playing devil's
advocate.


* except for Mutt, I don't think it actually has a menu item. But it's
possible to set it as your mailer via the dialog)
Comment 2 Bryan W Clark 2004-09-03 17:42:35 EDT
This is a problem with using the launchemail script.  I'm not sure why
that is still included with the install since we have a "Preffered
Applications" system handling this method but perhaps it hasn't been
fixed since the 2.6 days.

In fact if you look at the launchemail script it contains this:

# WARNING: Deprecated Script
# This script exists only because GNOME 2.6 gnome-open lacks the ability
# to launch the preferred mail application directly without arguments.
# This script will be replaced for target distribution FC3 when
# something better is implemented upstream.

Should CC Warren on this to get a status on this.
Comment 3 Bryan W Clark 2004-09-14 14:57:36 EDT
If launchmail is still needed because no decent gnome-open replacement
exists then we need to remove it's .desktop menu entry to avoid the
duplication of menu items.
Comment 4 Dave Malcolm 2004-09-15 19:31:12 EDT
OK - launchmail is provided by package htmlview, and contains the
offending desktop file: /usr/share/applications/redhat-email.desktop

Reassigning to component "htmlview"
Comment 5 Warren Togami 2004-09-15 19:35:15 EDT

*** This bug has been marked as a duplicate of 125865 ***
Comment 6 Warren Togami 2004-09-15 21:10:31 EDT
[root@ibmlaptop applications]# rpm -qf evolution-2.0.desktop
evolution-1.5.94.1-1
[root@ibmlaptop applications]# ls -l evolution-2.0.desktop
-rw-r--r--  1 root root 2468 Sep 15 14:58 evolution-2.0.desktop
Actually, this was an evolution problem.  evolution sometime after
FC2 began providing its own .desktop file.

Comment 7 Warren Togami 2004-09-15 21:15:29 EDT
And mozilla stopped providing the symlink to the redhat-menus desktop
file sometime after FC2, so it is not exhibiting this problem.

The "solution" for this is either evolution-2.0.desktop should be
removed, or this line be added:
OnlyShowIn=;

This however does not fix Zack's concern in Comment #1, which is
exactly the reason I made it this way in FC2.  It would have been more
obvious if I had different icons for evolution & preferred e-mail
launcher, but I ran out of time.
Comment 8 Warren Togami 2004-09-15 21:25:20 EDT
Oops... I forgot about the earlier agreed upon solution, which is the
opposite of the above:
1) evolution and mozilla should provide their own desktop files which
launch the applications directly.
2) redhat-menus provides the generic Preferred Application launcher
.desktop files, which contain OnlyShowIn=; so they are usable for the
default gnome-panel schema, but not visible as "duplicates" within the
menu.

closing again as duplicate

*** This bug has been marked as a duplicate of 125865 ***
Comment 9 Red Hat Bugzilla 2006-02-21 14:05:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.