Bug 125865 - Duplicate menu entries for mail and web browser
Duplicate menu entries for mail and web browser
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: htmlview (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Jonathan Blandford
:
: 122813 131747 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-12 15:43 EDT by Havoc Pennington
Modified: 2013-04-02 00:19 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-22 11:13:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2004-06-12 15:43:22 EDT
No .desktop file can contain Exec=htmlview, this is broken.

 - you can't know whether to fill in StartupNotify and other 
   such fields
 - you can't avoid duplicate menu entries for the browser
   launched by htmlview

redhat-web.desktop and redhat-email.desktop are supposed to point
directly to the default browser, included in redhat-menus for
translation, and symlinked to by the package that contains the default
browser. (s/browser/mailclient/ as well)

This bug should be an FC3 blocker.
Comment 1 petrosyan 2004-06-17 08:01:16 EDT
*** Bug 122813 has been marked as a duplicate of this bug. ***
Comment 2 Ivan Gyurdiev 2004-08-16 01:20:23 EDT
65 days later I still see duplicate mail and browser icons, so 
as far as I can tell no progress has been made.

Comment 3 Havoc Pennington 2004-08-16 15:49:32 EDT
This will be fixed in FC3.
Comment 4 Warren Togami 2004-09-15 19:35:20 EDT
*** Bug 131747 has been marked as a duplicate of this bug. ***
Comment 5 Warren Togami 2004-09-15 19:39:32 EDT
Havoc analysis is slightly incorrect.  I have a suggested fixed
implementation coming soon.
Comment 6 Warren Togami 2004-09-15 20:25:10 EDT
Hmm, I am seriously confused.  I know how to fix this, but my menus
are missing the duplicate Mozilla and Evolution despite everything
indicating they should be there.
Comment 7 Warren Togami 2004-09-15 21:25:45 EDT
*** Bug 131747 has been marked as a duplicate of this bug. ***
Comment 10 petrosyan 2004-12-22 01:45:47 EST
this bug has been fixed in Fedora Core 3

Note You need to log in before you can comment on or make changes to this bug.