Bug 1317477 - Mouse cursor not visible on overview in GNOME X session
Summary: Mouse cursor not visible on overview in GNOME X session
Keywords:
Status: CLOSED DUPLICATE of bug 1316010
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-14 10:48 UTC by Jacobo Aragunde
Modified: 2016-03-17 11:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-17 11:27:04 UTC
Type: Bug


Attachments (Terms of Use)
Screen position setup screenshot (91.24 KB, image/png)
2016-03-14 13:15 UTC, Jacobo Aragunde
no flags Details

Description Jacobo Aragunde 2016-03-14 10:48:34 UTC
Description of problem:

The mouse cursor is not visible in the overview or when the cursor is on some element of the shell like the top bar or its menus. It's also invisible when a shell dialog, like the logout dialog, pops up.

Version-Release number of selected component (if applicable):

Fedora 23, just upgraded from F22; GNOME 3.18.2.

How reproducible:

Always.

Steps to Reproduce:
1. Log into a GNOME X session.
2. Open the overview with super or the hot corner.

Actual results:

Mouse cursor disappears.

Expected results:

Mouse cursor keeps being visible.

Additional info:

Only reproducible in a GNOME X session, not in Wayland.

Comment 1 Jacobo Aragunde 2016-03-14 11:30:16 UTC
It seems this only happens in my own user profile. New, clean user profiles don't have this problem.

Comment 2 Jacobo Aragunde 2016-03-14 13:14:25 UTC
(In reply to Jacobo Aragunde from comment #1)
> It seems this only happens in my own user profile. New, clean user profiles
> don't have this problem.

New user profiles didn't have the problem... Until I started applying my usual preferences :)

I have a two-screen setup, and the bug started happening again when I changed the position of my screens. New steps to reproduce the bug:

0. Connect two screens to your PC, of different sizes preferably.
1. Go to settings -> screens -> change position.
2. Change the relative position of the secondary screen regarding the primary screen.
3. Apply changes.
4. Log out and in again.

Comment 3 Jacobo Aragunde 2016-03-14 13:15:44 UTC
Created attachment 1136143 [details]
Screen position setup screenshot

The configuration shown in the screenshot is causing this bug in my case.

Comment 4 Florian Müllner 2016-03-17 11:27:04 UTC

*** This bug has been marked as a duplicate of bug 1316010 ***


Note You need to log in before you can comment on or make changes to this bug.