Bug 1316010 - Mouse pointer is invisible over gnome-shell overview and top bar
Summary: Mouse pointer is invisible over gnome-shell overview and top bar
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 23
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1315413 1316957 1317477 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-09 08:58 UTC by Adrien Vergé
Modified: 2016-03-17 11:27 UTC (History)
16 users (show)

Fixed In Version: mutter-3.18.3-2.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-13 23:53:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 763159 None None None 2016-03-09 11:48:59 UTC

Description Adrien Vergé 2016-03-09 08:58:40 UTC
Description of problem:

With update to mutter-3.18.3-1.fc23, mouse cursor becomes invisible when over top bar (Activities, etc.) or in "overview" mode (super key). It is possible to click, but not to see where the cursor is. The pointer gets visible again when over normal windows. Downgrading to mutter-3.18.1-4.fc23 solves the problem.

Version-Release number of selected component (if applicable):

3.18.3-1

How reproducible: on a Gnome shell environment

Steps to Reproduce:
1. Install mutter-3.18.3-1.fc23
2. Reload shell (Alt+F2 then 'r')

Actual results:

Mouse pointer disappears when over top bar or in "overview" mode.

Expected results:

Mouse pointer does not disappear at all.

Additional info:

Fedora 23
GNOME Shell 3.18.4

Bug also reported at:
- http://forums.fedoraforum.org/showthread.php?p=1756210
- https://bugs.archlinux.org/task/48505

Comment 1 Jiri Eischmann 2016-03-09 10:36:03 UTC
I can confirm this after the last update. It only occurs on Xorg, works fine on Wayland.

Comment 2 Volker Sobek 2016-03-09 21:25:54 UTC
Same issue for me after the last update [0]. I don't see the mouse pointer while in the Activities overview. The cursor is there when using a wayland session, but not with Xorg. Meanwhile, after some time of using gnome-shell, the mouse pointer is now visible again in the overview.

[0]
$ sudo pkcon offline-status
Status:	Success
Updated glibc-common-2.22-11.fc23.x86_64
Updated glibc-2.22-11.fc23.x86_64
Updated php-common-5.6.19-1.fc23.x86_64
Updated gnutls-3.4.10-1.fc23.x86_64
Updated glusterfs-libs-3.7.8-2.fc23.x86_64
Updated selinux-policy-3.13.1-158.9.fc23.noarch
Updated glusterfs-3.7.8-2.fc23.x86_64
Updated glusterfs-client-xlators-3.7.8-2.fc23.x86_64
Updated gnutls-dane-3.4.10-1.fc23.x86_64
Updated cockpit-bridge-0.96-1.fc23.x86_64
Updated cockpit-shell-0.96-1.fc23.noarch
Updated selinux-policy-targeted-3.13.1-158.9.fc23.noarch
Updated gnutls-c++-3.4.10-1.fc23.x86_64
Updated wireshark-1.12.10-1.fc23.x86_64
Updated php-cli-5.6.19-1.fc23.x86_64
Updated php-pdo-5.6.19-1.fc23.x86_64
Updated cockpit-ws-0.96-1.fc23.x86_64
Updated glibc-headers-2.22-11.fc23.x86_64
Updated librados2-1:0.94.6-1.fc23.x86_64
Updated mutter-3.18.3-1.fc23.x86_64
Updated gnome-shell-3.18.4-1.fc23.x86_64
Updated gnome-shell-extension-common-3.18.4-1.fc23.noarch
Updated gnome-shell-extension-alternate-tab-3.18.4-1.fc23.noarch
Updated gnome-shell-extension-apps-menu-3.18.4-1.fc23.noarch
Updated gnome-shell-extension-launch-new-instance-3.18.4-1.fc23.noarch
Updated gnome-shell-extension-places-menu-3.18.4-1.fc23.noarch
Updated gnome-shell-extension-window-list-3.18.4-1.fc23.noarch
Updated cockpit-storaged-0.96-1.fc23.noarch
Updated cockpit-networkmanager-0.96-1.fc23.noarch
Updated cockpit-docker-0.96-1.fc23.x86_64
Updated cockpit-0.96-1.fc23.x86_64
Updated gnome-classic-session-3.18.4-1.fc23.noarch
Updated gnome-shell-extension-user-theme-3.18.4-1.fc23.noarch
Updated librbd1-1:0.94.6-1.fc23.x86_64
Updated glibc-devel-2.22-11.fc23.x86_64
Updated php-mysqlnd-5.6.19-1.fc23.x86_64
Updated php-5.6.19-1.fc23.x86_64
Updated wireshark-gnome-1.12.10-1.fc23.x86_64
Updated gnutls-devel-3.4.10-1.fc23.x86_64
Updated selinux-policy-sandbox-3.13.1-158.9.fc23.noarch
Updated gnutls-utils-3.4.10-1.fc23.x86_64
Updated glusterfs-fuse-3.7.8-2.fc23.x86_64
Updated glusterfs-api-3.7.8-2.fc23.x86_64
Updated selinux-policy-doc-3.13.1-158.9.fc23.noarch
Updated selinux-policy-devel-3.13.1-158.9.fc23.noarch
Updated php-xml-5.6.19-1.fc23.x86_64
Updated php-tidy-5.6.19-1.fc23.x86_64
Updated php-process-5.6.19-1.fc23.x86_64
Updated php-mbstring-5.6.19-1.fc23.x86_64
Updated php-intl-5.6.19-1.fc23.x86_64
Updated php-gmp-5.6.19-1.fc23.x86_64
Updated php-gd-5.6.19-1.fc23.x86_64
Updated php-bcmath-5.6.19-1.fc23.x86_64
Updated geocode-glib-3.18.2-1.fc23.x86_64
Updated glibc-utils-2.22-11.fc23.x86_64
Updated libbluray-0.9.2-1.fc23.x86_64
Updated parted-3.2-16.fc23.x86_64
Updated xfsprogs-4.3.0-1.fc23.x86_64
Updated breeze-cursor-theme-5.5.5-1.fc23.noarch
Updated glibc-2.22-11.fc23.i686
Updated gnutls-3.4.10-1.fc23.i686

Comment 3 Florian Müllner 2016-03-10 12:18:31 UTC
*** Bug 1315413 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2016-03-10 16:35:26 UTC
mutter-3.18.3-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-30ef48bcb6

Comment 5 Adrien Vergé 2016-03-11 07:59:15 UTC
Florian, mutter-3.18.3-2.fc23 solves the problem on my machine. Thanks!

Comment 6 Major Hayden 2016-03-11 14:38:45 UTC
*** Bug 1316957 has been marked as a duplicate of this bug. ***

Comment 7 Major Hayden 2016-03-11 14:46:58 UTC
mutter-3.18.3-2.fc23 fixes the cursor disappearance bug for me as well. :)

Thanks so much!

Comment 8 Alex Markley 2016-03-11 18:10:10 UTC
I'm able to confirm that mutter-3.18.3-2.fc23 fixes this issue for me on my laptop. Thanks!

Comment 9 Fedora Update System 2016-03-12 17:25:50 UTC
mutter-3.18.3-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-30ef48bcb6

Comment 10 Fedora Update System 2016-03-13 23:53:04 UTC
mutter-3.18.3-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Florian Müllner 2016-03-17 11:27:04 UTC
*** Bug 1317477 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.