Bug 131762 - Missing /dev/cdrom and /dev/sr0 when using kernel-2.6.8-1.541
Summary: Missing /dev/cdrom and /dev/sr0 when using kernel-2.6.8-1.541
Status: CLOSED DUPLICATE of bug 133841
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-04 00:49 UTC by Mike
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike 2004-09-04 00:49:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040619

Description of problem:
As the summary notes my cdrom and sr0 devices are not installed with 
the 2.6.8-1.541 kernel.  Reverting back to the 2.6.8-1.535 kernel 
brings the devices back.  This is on a firewire based cdrom (Sony 
VAIO laptop).

The dmesg logs for the two kernel versions are here:

2.6.8-1.535

http://www.futzin.com/dmesg-535.txt

2.6.8-1.541

http://www.futzin.com/dmesg-541.txt

and while the symptom comes and goes with the version of kernel I 
use, I'm not sure which other packages, if any, may actually be 
responsible for this (any handy hints?)

After booting, I can modprobe "sr_mod" to get /dev/sr0.

I've put the output from lsmod here:

2.6.8-1.535

http://www.futzin.com/lsmod-535.txt

2.6.8-1.541

http://www.futzin.com/lsmod-541.txt

Regards, Mike Klinke

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.541

How reproducible:
Always

Steps to Reproduce:
1.boot into kernel 541
2.
3.
    

Actual Results:  /dev/cdrom and /dev/sr0 are missing

Expected Results:  the /dev files mentioned above to be present

Additional info:

Comment 1 Brian Millett 2004-09-04 01:34:21 UTC
Not just firewire.  Plain jane toshiba satellite laptop.  No /dev/cd*,
just /dev/hdc. For cd/dvd  I have to go back to at least 2.6.7-1.517
to use k3b, but that is another bug.  With 541, I get a lot of error
messages at boot time about the /dev file system.  Sorry, but I do not
know how to capture or retain those messages as they are not written
to /var/log/messages  My udev & dev & MAKEDEV & initscripts are:

dev-3.11-1
initscripts-7.77-1
udev-030-18
MAKEDEV-3.11-1

Comment 2 Jef Spaleta 2004-09-04 13:44:01 UTC
I see a similar issue  on 541  invovling the sg module and my usb scanner

I have to manually modprobe sg with 541 and then sane-find-scanner
detects my scanner.  I revert back to kernel 535 and the manual
modprobe of sg is unneeded. All other package versions are the same
and synced with rawhide as of Sep 3 noon EST.


-jef

Comment 3 Alexandre Oliva 2004-09-07 13:56:04 UTC
I doubt this has anything to do with the actual kernel, but rather
with the addition of initrd-time udev in recent mkinitrd versions. 
Try re-creating the initrd for the latest kernel with mkinitrd
--noudev, or re-create the initrd for the older kernel, and you'll
probably see the behavior change without change in the underlying kernel.

Comment 4 Brian Millett 2004-09-07 14:05:06 UTC
Right.  A solution to the udev problem for me runing 540 kernel is
here at this bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=131763


Comment 5 Mike 2004-09-08 00:35:59 UTC
This problem resolved for me thanks to the discussion concerning
udev.conf in comment #7 of Bug 131763.

Comment 6 Harald Hoyer 2004-09-22 12:38:12 UTC
the new udev package creates /dev/cdrom links and renames /dev/sr? to
/dev/scd?

Comment 7 Brian Millett 2004-09-22 13:09:55 UTC
Ok, but what happened to /dev/dvd ?  

Comment 8 Harald Hoyer 2004-09-27 13:27:26 UTC
did that exist ever?

Comment 9 Brian Millett 2004-09-27 14:41:13 UTC
Sure, ogle defaults to /dev/dvd as does xine.  
If I create the symlink, then it is gone at next boot.
I tried adding this to the 50-udev.rules
KERNEL="hd[a-z]", PROGRAM="/bin/cat /proc/ide/%k/model | cut -d' ' -f
2", RESULT="DVD", NAME="%k", SYMLINK="dvd%e"

and remade the initrd, but it didn't work.

Comment 10 Harald Hoyer 2004-09-28 09:48:17 UTC
please use e.g. 10-udev.rules, so that it does not get overwritten by
the udev package. You do not have to remake your initrd for that.

$ /bin/cat /proc/ide/hdc/model |  cut -d' ' -f 2
DVD-RW

your rule does not always work. You cannot rely on the second word to
be DVD.

/proc/sys/dev/cdrom/info is the file to parse.

Comment 11 Brian Millett 2004-09-28 11:10:38 UTC
Thanks, That is perfect.

Comment 12 Harald Hoyer 2004-09-30 09:56:48 UTC

*** This bug has been marked as a duplicate of 133841 ***

Comment 13 Red Hat Bugzilla 2006-02-21 19:05:28 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.