Bug 133841 - sr_mod isnt "autoloaded"
sr_mod isnt "autoloaded"
Status: CLOSED DUPLICATE of bug 130746
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 131762 (view as bug list)
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-09-27 16:29 EDT by Dams
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2004-09-27 16:29:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Galeon/1.3.17

Description of problem:
I got an old cdrom scsi device which still works very well. 
But on FC3t2 the sr_mod module isnt automagically loaded : 
after boot time, if i want to access to the cdrom device, i have to
manually run "modprobe sr_mod". Then udev is creating the symlink but
it still belongs to root and i have to chown it to be able to access
it as a simple mortal user.

How reproducible: Always

Steps to Reproduce:
1. Find an scsi cdrom device
2. Plug it
3. Boot
    
Actual Results:
fstab is correct :
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
lsmod|grep sr_mod|wc -l -> 0
ls -l /dev/cdrom /dev/sr0 /dev/scd0 -> No such files or directories

Additional info:

I'm not sure this bug belongs to modutils. Could be kernel kmod bug or
udev's fault, I honestly dont know and i'm sorry if i had to pick one
 at [almost] random.
Comment 1 Bill Nottingham 2004-09-27 17:03:00 EDT
Throwing at udev for now.
Comment 2 Harald Hoyer 2004-09-28 06:00:05 EDT
Normally, if you insmod a scsi host adaptor it causes several hotplug
events, which are handled also by the scsi.agent, which loads the
sr_mod or other scsi related modules.
But if the scsi hostadapter module is loaded in the initrd, there is
no scsi.agent and also no sr_mod... thus no device nodes are created..
Doh!

We could replay some hotplug events on system start after initrd, to
get the full hotplug functionality. This is already done by udevstart,
but only for devices. 
Comment 3 Bill Nottingham 2004-09-28 23:38:38 EDT
We can also just put sr_mod in the initrd along with sd_mod.
Comment 4 Jeremy Katz 2004-09-29 11:33:34 EDT
It's going to be the case with more than just scsi.agent, though, I'd
think.  We probably really want to make sure that things get
generically done (although, yes, adding sr_mod will fix this specific
case)
Comment 5 Harald Hoyer 2004-09-30 05:57:01 EDT
*** Bug 131762 has been marked as a duplicate of this bug. ***
Comment 6 Harald Hoyer 2004-09-30 06:00:13 EDT
We need a real hotplug-replay mechanism...
Comment 7 Harald Hoyer 2004-10-01 05:09:40 EDT

*** This bug has been marked as a duplicate of 130746 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:05:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.