Bug 1317837 - Problems with lifecycle env list when using role for view only
Summary: Problems with lifecycle env list when using role for view only
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles
Version: 6.1.7
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: 6.2
Assignee: Eric Helms
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Keywords: FieldEngineering, Triaged
: 1372737 1420511 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-15 10:29 UTC by Kenny Tordeurs
Modified: 2018-12-06 20:49 UTC (History)
8 users (show)

(edit)
Clone Of:
: 1480354 (view as bug list)
(edit)
Last Closed: 2017-09-25 18:59:44 UTC


Attachments (Terms of Use)
role_filter (89.30 KB, image/png)
2016-03-15 10:29 UTC, Kenny Tordeurs
no flags Details
lifecycle-env (41.50 KB, image/png)
2016-03-15 10:30 UTC, Kenny Tordeurs
no flags Details
lc-env postfix (18.80 KB, image/png)
2016-11-21 13:26 UTC, Peter Ondrejka
no flags Details
lc-env-postfix-6.2 (20.33 KB, image/png)
2017-08-28 15:21 UTC, Peter Ondrejka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2803 normal SHIPPED_LIVE Satellite 6.2.12 bug fix update 2017-10-12 19:22:49 UTC
Foreman Issue Tracker 13905 None None None 2016-03-15 10:29 UTC

Description Kenny Tordeurs 2016-03-15 10:29:57 UTC
Created attachment 1136505 [details]
role_filter

Description of problem:
A user with a role assigned that allows to view some resources, like Lifecycle environments

There are two problems on the Lifecycle environments list page:

1)  "Add New Environment" buttons are displayed but when we click on them, you get a 403 error => a display issue.

2)  Environment names are not displayed in tables.


Version-Release number of selected component (if applicable):
Satellite 6.1.7

How reproducible:
100%

Steps to Reproduce:
1. Define a user role which is alloed to view lifecycle env
2. Visit the lifecycle env page
3.

Actual results:
1) Seeing the add lifecycle env buttons
2) not displaying the lifecycle env names

Expected results:
1) Not seeing the add lifecycle env buttons
2) displaying the lifecycle env names

Additional info:

Comment 1 Kenny Tordeurs 2016-03-15 10:30 UTC
Created attachment 1136506 [details]
lifecycle-env

Comment 2 Bryan Kearney 2016-04-27 19:18:28 UTC
Upstream bug assigned to ehelms@redhat.com

Comment 3 Bryan Kearney 2016-04-27 19:18:30 UTC
Upstream bug assigned to ehelms@redhat.com

Comment 4 Bryan Kearney 2016-05-10 20:17:59 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13905 has been closed

Comment 6 Peter Ondrejka 2016-11-21 13:26 UTC
Created attachment 1222395 [details]
lc-env postfix

Verified in Sat 6.3 snap 6, user with aforementioned permissions can view lc environments as expected and no add buttons appear (see attached screenshot)

Comment 7 Brad Buckingham 2017-02-27 20:30:56 UTC
*** Bug 1420511 has been marked as a duplicate of this bug. ***

Comment 9 Tomer Brisker 2017-08-01 11:01:53 UTC
*** Bug 1372737 has been marked as a duplicate of this bug. ***

Comment 11 Peter Ondrejka 2017-08-28 15:21 UTC
Created attachment 1319119 [details]
lc-env-postfix-6.2

Comment 12 Peter Ondrejka 2017-08-28 15:22:14 UTC
Verified on satellite-6.2.12-1.0.el7sat.noarch, see attached screenshot

Comment 14 errata-xmlrpc 2017-09-25 18:59:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2803


Note You need to log in before you can comment on or make changes to this bug.