Bug 1420511 - view_lifecycle_environments permission does not show lifecycle environments
Summary: view_lifecycle_environments permission does not show lifecycle environments
Keywords:
Status: CLOSED DUPLICATE of bug 1317837
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Lifecycle Environments
Version: 6.2.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 20:56 UTC by Dylan Gross
Modified: 2017-02-27 20:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-27 20:30:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 18708 None None None 2017-02-27 19:14:16 UTC

Description Dylan Gross 2017-02-08 20:56:58 UTC
Description of problem:

  view_lifecycle_environments will not show lifecycle environments on https://satellite6.example.com/lifecycle_environments

Version-Release number of selected component (if applicable):

   Red Hat Satellite 6.2.7

How reproducible:  Always
Steps to Reproduce:

1. Create additional lifecycle environments other than Library

2. Create a role with the following permissions:
(Miscellaneous)	access_dashboard
Lifecycle Environment	edit_lifecycle_environments, promote_or_remove_content_views_to_environments, view_lifecycle_environments
Location	view_locations
Organization	view_organizations

3. Assign a user to that role

4. Log in with that user and navigate to Content -> Lifecycle Environments (https://satellite-test/lifecycle_environments)


Actual results:

  You can see the presence of the tables showing Content Views and Content Hosts in each Lifecycle Environment, but the Clickable Content View name link is missing from the top of each, making them unable to be navigated or even discerned from each other.

Expected results:

  The Lifecycle Environment's name should appear at the top of each table section with a clickable link to the actual instance of the specific Lifecycle page


Additional info:

  - Adding the "create_lifecycle_environments" permission will allow the Lifecycle Environment names to show up and be clicked on.
  - Also, I can still directly view a Lifecycle Environment by going to the URL directly even without the "create_lifecycle_environments" permission (i.e. https://satellite-test/lifecycle_environments/5/details)

Comment 4 Brad Buckingham 2017-02-27 19:14:13 UTC
Created redmine issue http://projects.theforeman.org/issues/18708 from this bug

Comment 5 Brad Buckingham 2017-02-27 20:30:56 UTC
After further investigation, this bugzilla as a duplicate of bug 1317837.

*** This bug has been marked as a duplicate of bug 1317837 ***


Note You need to log in before you can comment on or make changes to this bug.