Bug 131786 - eject unable to find open device
eject unable to find open device
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eject (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
: 131976 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-04 10:54 EDT by Colin Charles
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-09 20:16:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Charles 2004-09-04 10:54:29 EDT
Description of problem: eject can't eject the CDROM device since
/dev/cdrom really doesn't exist any longer with hal/udev in FC3
test2(rawhide?).


Version-Release number of selected component (if applicable):
eject-2.0.13-9

How reproducible:
100%

Steps to Reproduce:
1. run eject from the console (as root, even)
  
Actual results:
eject: unable to find or open device for: `cdrom'

Expected results:
Will eject cdrom

Additional info: This is because hal/udev and the new FHS conformation
makes things look at /media instead. eject is hardwired to eject
/mnt/cdrom by default

So doing eject /media/cdrom works. eject should be fixed to do this
automatically.
Comment 1 Colin Charles 2004-09-05 04:58:36 EDT
Also, because now there's hal/udev, on an x86 laptop, it created
mountpoints for /media/dvdrom. Running eject, fails again
Comment 2 Bill Nottingham 2004-09-06 23:27:58 EDT
Rather, I'd think /dev/cdrom* should be created.
Comment 3 Ngo Than 2004-09-07 06:03:16 EDT
i cannot reproduce this probleme on my machine with udev/hal enable.

how do you mount your cdrom? using automount?
what is the cdrom mount device and mounntpoints?

could you please send me the output of "cat /proc/mounts" after cdrom
is mounted and the /etc/fstab. Thanks



Comment 4 Ngo Than 2004-09-07 06:31:45 EDT
i have upload a test version of eject, which probably fixes this
problem. please let me know if this problem is fixed. Thanks

ftp://people.redhat.com/than/rawhide/eject-2.0.13-10.i386.rpm
Comment 5 Ngo Than 2004-09-07 13:16:17 EDT
*** Bug 131976 has been marked as a duplicate of this bug. ***
Comment 6 Colin Charles 2004-10-09 20:16:46 EDT
Yes, this is fixed, closing as rawhide.

Note You need to log in before you can comment on or make changes to this bug.