Bug 131864 - cups starten: Traceback (most recent call last)
Summary: cups starten: Traceback (most recent call last)
Keywords:
Status: CLOSED DUPLICATE of bug 131563
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-05 23:14 UTC by Uwe Beck
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Uwe Beck 2004-09-05 23:14:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.4.3)
Gecko/20040803

Description of problem:
After U3 update there is a Traceback when cups daemon starts.
I see this Traceback at boot in runlevel 3 and also with

"service cups start" or "service cups restart".

Here is the Traceback:

# service cups restart
Stopping cups:                                             [  OK  ]
cups starten: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import backend
  File "/usr/share/printconf/util/backend.py", line 50, in ?
    which = cups_import.which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment
                                                           [  OK  ]
# 

This rpms are installed:
# rpm -qa | grep cups
gimp-print-cups-4.2.4-5
cups-devel-1.1.17-13.3.12
cups-libs-1.1.17-13.3.12
cups-1rpm -qa | grep cups

The cups daemon starts and I am able to print.
I see this Traceback on systems with configured printers and also on
systems without printers.

Version-Release number of selected component (if applicable):
cups-1.1.17-13.3.12

How reproducible:
Always

Steps to Reproduce:
1. Install the U3 cups errata
2. Boot the system or restart the cups service
3.
    

Actual Results:  cups starts with Traceback.

Expected Results:  cups should start without any errors.

Additional info:

User see this Traceback at system boot in runlevel 3 or if the user
restart the cups daemon.

Comment 1 Tim Waugh 2004-09-06 08:12:07 UTC

*** This bug has been marked as a duplicate of 131563 ***

Comment 2 Uwe Beck 2004-09-06 09:23:51 UTC
I use LANG=de_DE. The hack in #131563 fix the problem.
Let me test the new rpms from people.

Uwe



Comment 3 Uwe Beck 2004-09-06 09:46:45 UTC
The new rpms from
ftp://people.redhat.com/twaugh/tmp/redhat-config-printer/
fix the problem.

We need an offical errata fast as can.

Uwe


Comment 4 Red Hat Bugzilla 2006-02-21 19:05:29 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.