Bug 131563 - U3 breaks redhat-config-printer and cups
Summary: U3 breaks redhat-config-printer and cups
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 128702 131864 131933 131954 132649 132948 133331 133472 133877 135435 135817 137777 138290 140927 141692 (view as bug list)
Depends On:
Blocks: 123574
TreeView+ depends on / blocked
 
Reported: 2004-09-02 11:11 UTC by Terje Røsten
Modified: 2007-11-30 22:07 UTC (History)
18 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-12-21 01:44:23 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:473 normal SHIPPED_LIVE Updated redhat-config-printer packages 2004-12-20 05:00:00 UTC

Description Terje Røsten 2004-09-02 11:11:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040515 Firefox/0.8

Description of problem:
This not so clever hack:

def which_spooler ():
    """Return the name of the active spooler."""
    signal.signal (signal.SIGCHLD, signal.SIG_DFL)
    f = os.popen ('/usr/sbin/alternatives --display print')
    for l in f.readlines ():
        if l.startswith (" link currently points to"):
            which = l.split ('.')[1].strip ()
            break

    f.close ()
    return which

in the file /usr/share/printconf/util/cups_import.py

breaks, when locale is non-english.

See:

$ LC_ALL=no_NO /usr/sbin/alternatives --display print| head -3
print - status automatisk.
lenken peker nå til /usr/bin/lpr.cups

A hack on the hack fix this:


--- cups_import.py~     2004-03-06 14:19:02.000000000 +0100
+++ cups_import.py      2004-09-02 13:02:25.000000000 +0200
@@ -185,7 +185,7 @@
 def which_spooler ():
     """Return the name of the active spooler."""
     signal.signal (signal.SIGCHLD, signal.SIG_DFL)
-    f = os.popen ('/usr/sbin/alternatives --display print')
+    f = os.popen ('LC_ALL=C /usr/sbin/alternatives --display print')
     for l in f.readlines ():
         if l.startswith (" link currently points to"):
             which = l.split ('.')[1].strip ()


Not nice, but it works.





Version-Release number of selected component (if applicable):
edhat-config-printer-0.6.47.3.19-1
redhat-config-printer-0.6.47.3.19-1 cups-1.1.17-13.3.12 

How reproducible:
Always

Steps to Reproduce:
Use a non-english locale and use the printconf tool or start the cups
service.

Additional info:

Comment 1 Tim Waugh 2004-09-02 11:20:50 UTC
Thanks for reporting it.

Comment 2 Tim Waugh 2004-09-02 12:18:03 UTC
Please try 0.6.47.3.20-1 from this location:

ftp://people.redhat.com/twaugh/tmp/redhat-config-printer/



Comment 3 Terje Røsten 2004-09-02 17:28:13 UTC
I am running on x86-64, but a rebuild did the trick.

The bug is fixed, thanks for the quick response.

Comment 4 Tim Waugh 2004-09-02 17:30:33 UTC
Thanks for testing.  I'm leaving this open so that it can be tracked
for a future update.

Comment 5 Tim Waugh 2004-09-06 08:12:08 UTC
*** Bug 131864 has been marked as a duplicate of this bug. ***

Comment 6 Tim Waugh 2004-09-07 08:36:45 UTC
*** Bug 131933 has been marked as a duplicate of this bug. ***

Comment 7 Tim Waugh 2004-09-07 13:06:55 UTC
*** Bug 131954 has been marked as a duplicate of this bug. ***

Comment 8 Milan Kerslager 2004-09-21 13:52:14 UTC
*** Bug 132948 has been marked as a duplicate of this bug. ***

Comment 9 Milan Kerslager 2004-09-21 13:52:53 UTC
*** Bug 132649 has been marked as a duplicate of this bug. ***

Comment 10 Milan Kerslager 2004-09-21 14:43:58 UTC
If anybody interested to use LC_ALL=C fix only backported to the
current U3 redhat-config-printer, use my repository:

ftp://ftp.vslib.cz/pub/local/milan.kerslager/RHEL-3/fix.redhat-config-printer/
ftp://ftp.linux.cz/pub/linux/people/milan_kerslager/RHEL-3/

Comment 11 Tim Waugh 2004-09-23 11:14:18 UTC
*** Bug 133331 has been marked as a duplicate of this bug. ***

Comment 12 Tim Waugh 2004-09-24 09:43:20 UTC
*** Bug 133472 has been marked as a duplicate of this bug. ***

Comment 13 Tim Waugh 2004-09-28 08:38:10 UTC
*** Bug 133877 has been marked as a duplicate of this bug. ***

Comment 14 Tim Waugh 2004-09-28 12:34:47 UTC
*** Bug 128702 has been marked as a duplicate of this bug. ***

Comment 16 Tim Waugh 2004-10-13 13:10:30 UTC
*** Bug 135435 has been marked as a duplicate of this bug. ***

Comment 17 Tim Waugh 2004-10-15 09:03:57 UTC
*** Bug 135817 has been marked as a duplicate of this bug. ***

Comment 18 Tim Waugh 2004-11-01 09:25:02 UTC
*** Bug 137777 has been marked as a duplicate of this bug. ***

Comment 19 adnet eric 2004-11-03 17:04:06 UTC
I have the same bug with system-config-printer-0.6.98-1

Have you any solution for this version ?

Comment 20 adnet eric 2004-11-04 07:52:20 UTC
I have the same bug with system-config-printer-0.6.98-1

Have you any solution for this version ?

Comment 21 adnet eric 2004-11-04 09:14:49 UTC
My problem is solve, just make a :
rpm -Uvh --oldpackage cups-libs-1.1.20-6.i386.rpm

Comment 22 Tim Waugh 2004-11-08 16:06:26 UTC
*** Bug 138290 has been marked as a duplicate of this bug. ***

Comment 23 Tim Waugh 2004-11-26 15:59:08 UTC
*** Bug 140927 has been marked as a duplicate of this bug. ***

Comment 24 Tim Waugh 2004-12-03 09:50:11 UTC
*** Bug 141692 has been marked as a duplicate of this bug. ***

Comment 25 John Flanagan 2004-12-21 01:44:23 UTC
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-473.html



Note You need to log in before you can comment on or make changes to this bug.