Bug 131915 - pxdvi won't print -- bug in /usr/bin/xdviprint
pxdvi won't print -- bug in /usr/bin/xdviprint
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-06 14:18 EDT by D. Hugh Redelmeier
Modified: 2013-07-02 19:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.0.2-23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-08 09:46:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D. Hugh Redelmeier 2004-09-06 14:18:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
pxdvi's print function does not work:
  /usr/bin/xdviprint: line 38: /tmp/xdviprint.3931.dvi: Permission denied
  lpr: unable to print file: client-error-bad-request

The problem is in the script /usr/bin/xdviprint.  The variable
DVIPSCMD is not initialized, but is used as the command to be invoked.
 In fact, the script has 3 commands to set this, each commented out.

Here is a diff of a work around.  I think that the true fix involves
some upstream configuration script:
--- /usr/bin/xdviprint.ORIGINAL 2004-03-25 11:05:05.000000000 -0500
+++ /usr/bin/xdviprint  2004-09-06 14:09:31.241743856 -0400
@@ -14,8 +14,8 @@
 ###### DVI -> PS
 ######
 ## for dvips
-# FILTOPTTBL=${XDVIFILTOPTTBL:-/usr/share/texmf/pxdvi/xdvipaper.dvips}
-# DVIPSCMD="dvips -f -t"
+FILTOPTTBL=${XDVIFILTOPTTBL:-/usr/share/texmf/pxdvi/xdvipaper.dvips}
+DVIPSCMD="dvips -R -f -t"
 ####
 ## for dvi2ps
 # FILTOPTTBL=${XDVIFILTOPTTBL:-/usr/share/texmf/pxdvi/xdvipaper.dvi2ps-j}



Version-Release number of selected component (if applicable):
tetex-dvips-2.0.2-13

How reproducible:
Always

Steps to Reproduce:
1. find some .dvi file to print (for example, octave package contains one)
2. run pxdvi: pxdvi dvifile
3. select "print", "current page"
    

Actual Results:  stderr gets error messages; no printout
 /usr/bin/xdviprint: line 38: /tmp/xdviprint.3931.dvi: Permission denied
  lpr: unable to print file: client-error-bad-request


Expected Results:  printout of DVI page

Additional info:

our tentative change to /usr/bin/xdviprint seems to be part of the
patch mentioned in bug 101954.
Comment 1 Tim Waugh 2004-09-10 09:52:43 EDT
Fixed in CVS.
Comment 2 Jindrich Novy 2004-11-01 07:50:19 EST
Ok, Tim added the -R option, but forgot to uncomment the lines.
It's now really fixed in CVS.

Note You need to log in before you can comment on or make changes to this bug.