Bug 131933 - /usr/sbin/alternatives's message translation breaks printtool
Summary: /usr/sbin/alternatives's message translation breaks printtool
Status: CLOSED DUPLICATE of bug 131563
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: chkconfig (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-07 01:49 UTC by CHIKAMA Masaki
Modified: 2014-03-17 02:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description CHIKAMA Masaki 2004-09-07 01:49:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.4.3)
Gecko/20040803

Description of problem:
When I use printtool command with LANG=ja_JP,
I cannot execute command with these messages.

Traceback (most recent call last):
  File "/usr/sbin/printtool", line 7, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 945, in ?
    queueTree()
  File "/usr/share/printconf/util/queueTree.py", line 102, in __init__
    if cups_import.import_needed ():
  File "/usr/share/printconf/util/cups_import.py", line 200, in
import_needed
    which = which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment


This is because in cups_import.py

def which_spooler ():
    """Return the name of the active spooler."""
    signal.signal (signal.SIGCHLD, signal.SIG_DFL)
    f = os.popen ('/usr/sbin/alternatives --display print')
    for l in f.readlines ():
        if l.startswith (" link currently points to"):
            which = l.split ('.')[1].strip ()
            break
 
    f.close ()
    return which

the output message "/usr/sbin/alternatives --display print" 
is translated (into Japanese).



Version-Release number of selected component (if applicable):
chkconfig-1.3.11-0.3

How reproducible:
Always

Steps to Reproduce:
1. LANG=ja_JP printttool
2.
3.
    

Additional info:

Comment 1 Tim Waugh 2004-09-07 08:36:43 UTC

*** This bug has been marked as a duplicate of 131563 ***

Comment 2 CHIKAMA Masaki 2004-09-07 09:31:39 UTC
Thank you. The new package in #131563 fix the problem.


Comment 3 Red Hat Bugzilla 2006-02-21 19:05:29 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.