Bug 1319399 - "Could not find plugin 'GStreamer' for application 'amarok'"
Summary: "Could not find plugin 'GStreamer' for application 'amarok'"
Keywords:
Status: CLOSED DUPLICATE of bug 1327360
Alias: None
Product: Fedora
Classification: Fedora
Component: amarok
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-19 12:55 UTC by Martin Kho
Modified: 2016-04-20 23:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-20 23:16:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin Kho 2016-03-19 12:55:53 UTC
Description of problem:
No music, which is rather annoying for a media player ;-) The complete error message is:

amarok(6219)/phonon (KDE plugin): Can not create backend object from factory for  "GStreamer" ,  "phonon_gstreamer" :
 "Could not find plugin 'GStreamer' for application 'amarok'" 
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded

Settings -> Configure Amarok -> Playback -> Configure Phonon -> Device Preference is empty. The Front Left and Front Right buttons (Audio Hardware Setup tab) are working correct.

No problems with sound in other applications.

Version-Release number of selected component (if applicable):
amarok-2.8.90-5.fc24.x86_64

phonon-backend-gstreamer-4.8.2-6.fc24.x86_64
phonon-4.8.3-9.fc24.x86_64
phonon-qt5-backend-gstreamer-4.8.2-6.fc24.x86_64
phonon-qt5-4.8.3-9.fc24.x86_64

gstreamer1-plugins-base-1.7.91-1.fc24.x86_64
qt5-gstreamer-1.2.0-8.fc24.x86_64
gstreamer1-plugins-good-1.7.91-1.fc24.x86_64
libnice-gstreamer1-0.1.13-3.fc24.x86_64
phonon-backend-gstreamer-4.8.2-6.fc24.x86_64
qt-gstreamer-1.2.0-8.fc24.x86_64
gstreamer1-1.7.91-1.fc24.x86_64
gstreamer1-plugins-bad-free-1.7.91-1.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start Amarok
2. Play a - local - track
3.

Actual results:
No sound

Expected results:
Track is audible

Additional info:

Comment 1 Saurabh Pradhan 2016-04-19 18:25:06 UTC
Same problem here. Running into debugging mode gives this warning.
--
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded

Comment 3 Rex Dieter 2016-04-19 19:29:30 UTC
or possibly,
https://bodhi.fedoraproject.org/updates/FEDORA-2016-d3a880fb8c

we're sorting out a qt4 plugin issue for some stuff built erroneously by gcc6

*** This bug has been marked as a duplicate of bug 1327360 ***

Comment 4 Rex Dieter 2016-04-20 10:09:44 UTC
amarok, phonon, phonon-backend-gstreamer all have the proper qt buildkey now:
buildkey=x86_64 linux g++-4 full-config

So, it's problem is apparently something other than the issue tracked in bug #1327360  , re-opening

Comment 5 Rex Dieter 2016-04-20 15:32:45 UTC
See latest bug #1327360 , comment, but it would appear the latest batch of builds in fact did not fix the problem (but introduced yet another different/incompatible QT_BUILD_KEY).  

Short version: this issue is (still) probably a dup of bug #1327360 , but I'll double/triple check it this time before marking it as such

Comment 6 Rex Dieter 2016-04-20 23:16:52 UTC
confirmed fixed qt/phonon takes care of this, remarked as dup, updates coming soon

*** This bug has been marked as a duplicate of bug 1327360 ***


Note You need to log in before you can comment on or make changes to this bug.