Bug 1327360 - qt > 4.8.7-6.fc24 fails to load any plugins (including styles)
Summary: qt > 4.8.7-6.fc24 fails to load any plugins (including styles)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker AcceptedFreezeException
: 1319399 (view as bug list)
Depends On:
Blocks: F24BetaFreezeException F24FinalBlocker 1328865
TreeView+ depends on / blocked
 
Reported: 2016-04-14 21:56 UTC by Sandro Mani
Modified: 2016-04-23 23:43 UTC (History)
12 users (show)

Fixed In Version: qt-4.8.7-17.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-23 23:43:19 UTC


Attachments (Terms of Use)

Description Sandro Mani 2016-04-14 21:56:47 UTC
Description of problem:
Any version after qt-4.8.7-6.fc24 fails to load plugins. Most noticeable because the application fails to load the style plugins. Other applications, such as qpdfview, are unusable because they can't load the necessary plugins.

Suspect an issue related to GCC6, i.e. qt = 4.8.7-6.fc24 is the version before the GCC6 mass rebuild.

Version-Release number of selected component (if applicable):
qt > 4.8.7-6.fc24

How reproducible:
Always

Comment 1 Rex Dieter 2016-04-15 02:35:42 UTC
OK, I found this:

$ KDE_FULL_SESSION= qpdfview
Could not load plug-in in first attempt: "" 
"The shared library was not found." 
Could not load plug-in in second attempt: "/usr/lib64/qpdfview/libqpdfview_pdf.so" 
"The plugin '/usr/lib64/qpdfview/libqpdfview_pdf.so' uses incompatible Qt library. Expected build key "x86_64 linux g++-6.0.0 full-config", got "x86_64 linux g++-4 full-config"" 
Could not load plug-in in first attempt: "" 
"The shared library was not found." 
Could not load plug-in in second attempt: "/usr/lib64/qpdfview/libqpdfview_ps.so" 
"The plugin '/usr/lib64/qpdfview/libqpdfview_ps.so' uses incompatible Qt library. Expected build key "x86_64 linux g++-6.0.0 full-config", got "x86_64 linux g++-4 full-config"" 
Could not load plug-in in first attempt: "" 
"The shared library was not found." 
Could not load plug-in in second attempt: "/usr/lib64/qpdfview/libqpdfview_djvu.so" 
"The plugin '/usr/lib64/qpdfview/libqpdfview_djvu.so' uses incompatible Qt library. Expected build key "x86_64 linux g++-6.0.0 full-config", got "x86_64 linux g++-4 full-config""

Comment 2 Rex Dieter 2016-04-15 02:44:00 UTC
rebuilding qpdfview fixes it, though I'll need to verify what we really want for build key here.

Comment 3 Kevin Kofler 2016-04-15 10:26:32 UTC
There is already a patch to support GCC 5 for the build key, we just need to fix it to support >5, too. I think that when I did that patch, I did not realize that GCC was not going to stay on 5.x.x for long, I was expecting 5.x.x to last at least as long as 4.x.x did. But GCC has joined the Chromium/Firefox version race now. :-(

Comment 4 Kevin Kofler 2016-04-15 10:26:59 UTC
(The build key should be g++-4 for any GCC >= 4.)

Comment 5 Rex Dieter 2016-04-15 12:08:20 UTC
Yeah, I think I can confirm the buildkey is borked, which means :

1.  fixing qt
2.  rebuilding everything that had been built against the bad/tainted qt

:(

Comment 6 Rex Dieter 2016-04-15 12:30:16 UTC
qt.spec
%changelog
* Fri Apr 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 1:4.8.7-15
- %%build: -buildkey g++-4 (#1327360)

Comment 7 Kevin Kofler 2016-04-15 12:32:59 UTC
Yes, sadly, that's what it amounts to. :-(

Looks like we do not carry a patch to fix the build key in Qt 4 anymore, we're now using what upstream ships and that's broken. Grrr… Thanks for the fix!

Comment 8 Rex Dieter 2016-04-15 12:45:51 UTC
Kevin, instead of rebuilding everything, do you think we could perhaps limit it to only packages that provide plugins (ie, include anything that matches */*.so)?

Comment 9 Rex Dieter 2016-04-15 13:25:17 UTC
Filed,
https://fedorahosted.org/rel-eng/ticket/6392

for rel-eng assistance for implementing comment #5

Comment 10 Fedora Blocker Bugs Application 2016-04-15 17:57:24 UTC
Proposed as a Blocker and Freeze Exception for 24-beta by Fedora user rdieter using the blocker tracking app because:

 Building Qt (4) with gcc6 inadvertantly changed it's internal BUILD_KEY used to enforce loading/compatibility with loading plugins.  As a result, all Qt4 applications built after the initial f24 mass rebuild that use or include plugins can fail to run properly.

I've filed https://fedorahosted.org/rel-eng/ticket/6392 for rel-eng assistance to 1. identify affected packages and 2. perform mini-mass rebuild(s) as needed

Comment 11 Fedora Update System 2016-04-15 23:36:03 UTC
qt-4.8.7-15.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d3a880fb8c

Comment 12 Fedora Update System 2016-04-15 23:36:21 UTC
qt-4.8.7-15.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d3a880fb8c

Comment 13 Fedora Update System 2016-04-18 04:56:04 UTC
qt-4.8.7-15.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d3a880fb8c

Comment 14 Fedora Update System 2016-04-18 14:31:56 UTC
libkscreen-1.0.5-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-768f3efb03

Comment 15 Fedora Update System 2016-04-18 14:35:09 UTC
kdepimlibs-4.14.10-11.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7c11cc2120

Comment 16 Fedora Update System 2016-04-18 14:36:14 UTC
kde-workspace-4.11.22-11.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9e784dc962

Comment 17 Fedora Update System 2016-04-18 14:55:49 UTC
phonon-4.8.3-10.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7ef1bf2948

Comment 18 Fedora Update System 2016-04-18 16:00:46 UTC
libkscreen-1.0.5-8.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-768f3efb03

Comment 19 Fedora Update System 2016-04-18 16:01:25 UTC
kde-workspace-4.11.22-12.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9e784dc962

Comment 20 Fedora Update System 2016-04-18 16:33:36 UTC
kdepimlibs-4.14.10-12.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7c11cc2120

Comment 21 Fedora Update System 2016-04-18 16:38:59 UTC
phonon-4.8.3-11.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7ef1bf2948

Comment 22 Fedora Update System 2016-04-18 16:44:45 UTC
plasma-breeze-5.6.2-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cbfe737d6d

Comment 23 Fedora Update System 2016-04-18 16:45:36 UTC
plasma-oxygen-5.6.2-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-879e4b1ca3

Comment 24 Kamil Páral 2016-04-18 16:46:24 UTC
Discussed at today's blocker review meeting [1]. Voted as RejectedBlocker (Beta) AcceptedBlocker (Final) AcceptedFreezeException (Beta) - does not violate any of the Beta criteria, but does violate "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully..." in the case of qt4 apps installed with the KDE spin. It as accepted as a Beta FE for this reason.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-04-18

Comment 25 Fedora Update System 2016-04-18 16:49:09 UTC
qca-2.1.1-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7be0db6f54

Comment 26 Fedora Update System 2016-04-18 17:58:09 UTC
PyQt4-4.11.4-13.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7a50dfb512

Comment 27 Fedora Update System 2016-04-18 18:16:19 UTC
kde-baseapps-16.04.0-2.fc24 kde-runtime-16.04.0-2.fc24 kdelibs-4.14.19-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-83cfab51d0

Comment 28 Fedora Update System 2016-04-18 18:16:26 UTC
kde-baseapps-16.04.0-2.fc24 kde-runtime-16.04.0-2.fc24 kdelibs-4.14.19-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-83cfab51d0

Comment 29 Fedora Update System 2016-04-18 18:50:06 UTC
qca-2.1.1-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7be0db6f54

Comment 30 Fedora Update System 2016-04-18 18:50:11 UTC
plasma-oxygen-5.6.2-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-879e4b1ca3

Comment 31 Fedora Update System 2016-04-18 18:50:15 UTC
plasma-breeze-5.6.2-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cbfe737d6d

Comment 32 Fedora Update System 2016-04-18 18:50:21 UTC
phonon-4.8.3-11.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7ef1bf2948

Comment 33 Fedora Update System 2016-04-18 18:50:28 UTC
kde-workspace-4.11.22-12.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9e784dc962

Comment 34 Fedora Update System 2016-04-18 18:50:32 UTC
kdepimlibs-4.14.10-12.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7c11cc2120

Comment 35 Fedora Update System 2016-04-18 18:50:37 UTC
libkscreen-1.0.5-8.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-768f3efb03

Comment 36 Fedora Update System 2016-04-18 23:53:33 UTC
kdegraphics-mobipocket-16.04.0-1.fc24 kdegraphics-strigi-analyzer-16.04.0-1.fc24 kolourpaint-16.04.0-1.fc24 ksaneplugin-16.04.0-1.fc24 okular-16.04.0-1.fc24 svgpart-16.04.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8513cef496

Comment 37 Rex Dieter 2016-04-19 19:29:30 UTC
*** Bug 1319399 has been marked as a duplicate of this bug. ***

Comment 38 Fedora Update System 2016-04-19 20:24:52 UTC
kdegraphics-mobipocket-16.04.0-1.fc24, kdegraphics-strigi-analyzer-16.04.0-1.fc24, kolourpaint-16.04.0-1.fc24, ksaneplugin-16.04.0-1.fc24, okular-16.04.0-1.fc24, svgpart-16.04.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8513cef496

Comment 39 Fedora Update System 2016-04-19 20:26:10 UTC
PyQt4-4.11.4-13.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7a50dfb512

Comment 40 Fedora Update System 2016-04-19 20:26:23 UTC
kde-baseapps-16.04.0-2.fc24, kde-runtime-16.04.0-2.fc24, kdelibs-4.14.19-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-83cfab51d0

Comment 41 Fedora Update System 2016-04-19 20:29:44 UTC
qca-2.1.1-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 42 Fedora Update System 2016-04-19 20:29:57 UTC
phonon-4.8.3-11.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 43 Fedora Update System 2016-04-19 20:31:14 UTC
qt-4.8.7-15.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 44 Martin Kho 2016-04-20 09:40:49 UTC
Hi,

Sorry, not solved for amarok. Still same error.


Martin Kho

Comment 45 Sandro Mani 2016-04-20 09:42:20 UTC
I suppose Amarok (and other like qpdfview, qgis, ...) also need to be rebuilt?

Comment 46 Rex Dieter 2016-04-20 14:46:07 UTC
arg, seems at least some of these latest rebuilds set the wrong buildkey too.

some examples for comparison:

$ rpm -q phonon
phonon-4.8.3-11.fc24.x86_64

$ strings /usr/lib64/qt4/plugins/designer/libphononwidgets.so | grep buildkey
buildkey=g++-4 x86_64 linux g++-4 full-config


$ rpm -q tomahawk
tomahawk-0.8.4-9.fc24.x86_64

$ strings /usr/lib64/libtomahawk_configstorage_telepathy_kde.so | grep buildkey
buildkey=x86_64 linux g++-4 full-config

Comment 47 Fedora Update System 2016-04-20 15:24:16 UTC
kdegraphics-mobipocket-16.04.0-1.fc24, kdegraphics-strigi-analyzer-16.04.0-1.fc24, kolourpaint-16.04.0-1.fc24, ksaneplugin-16.04.0-1.fc24, okular-16.04.0-1.fc24, svgpart-16.04.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 48 Fedora Update System 2016-04-20 15:24:28 UTC
PyQt4-4.11.4-13.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 49 Fedora Update System 2016-04-20 15:24:35 UTC
plasma-oxygen-5.6.2-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 50 Fedora Update System 2016-04-20 15:24:39 UTC
plasma-breeze-5.6.2-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 51 Fedora Update System 2016-04-20 15:24:44 UTC
kde-workspace-4.11.22-12.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 52 Fedora Update System 2016-04-20 15:24:49 UTC
kdepimlibs-4.14.10-12.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 53 Fedora Update System 2016-04-20 15:24:54 UTC
libkscreen-1.0.5-8.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 54 Rex Dieter 2016-04-20 15:30:06 UTC
Another round of builds on the way

qt.spec:
%changelog
* Wed Apr 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 1:4.8.7-17
- %%build: drop --buildkey g++-4 (#1327360)
- %%build: add QT_BUILD_KEY verification (to avoid future regressions)

Comment 55 Rex Dieter 2016-04-20 23:16:52 UTC
*** Bug 1319399 has been marked as a duplicate of this bug. ***

Comment 56 Fedora Update System 2016-04-21 02:13:37 UTC
qt-4.8.7-17.fc24 kdelibs-4.14.19-3.fc24 kdepimlibs-4.14.10-13.fc24 kde-runtime-16.04.0-3.fc24 kde-baseapps-16.04.0-3.fc24 kde-workspace-4.11.22-13.fc24 phonon-4.8.3-12.fc24 libkscreen-1.0.5-9.fc24 qscintilla-2.9.2-3.fc24 plasma-breeze-5.6.3-2.fc24 plasma-oxygen-5.6.3-2.fc24 qca-2.1.1-6.fc24 PyQt4-4.11.4-14.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f1721e7f7d

Comment 57 Fedora Update System 2016-04-21 21:57:24 UTC
PyQt4-4.11.4-14.fc24, kde-baseapps-16.04.0-3.fc24, kde-runtime-16.04.0-3.fc24, kde-workspace-4.11.22-13.fc24, kdegraphics-mobipocket-16.04.0-2.fc24, kdegraphics-strigi-analyzer-16.04.0-2.fc24, kdelibs-4.14.19-3.fc24, kdepimlibs-4.14.10-13.fc24, kolourpaint-16.04.0-2.fc24, ksaneplugin-16.04.0-2.fc24, libkscreen-1.0.5-9.fc24, okular-16.04.0-2.fc24, phonon-4.8.3-12.fc24, plasma-breeze-5.6.3-2.fc24, plasma-oxygen-5.6.3-2.fc24, qca-2.1.1-6.fc24, qscintilla-2.9.2-3.fc24, qt-4.8.7-17.fc24, svgpart-16.04.0-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f1721e7f7d

Comment 58 Fedora Update System 2016-04-23 23:43:09 UTC
PyQt4-4.11.4-14.fc24, kde-baseapps-16.04.0-3.fc24, kde-runtime-16.04.0-3.fc24, kde-workspace-4.11.22-13.fc24, kdegraphics-mobipocket-16.04.0-2.fc24, kdegraphics-strigi-analyzer-16.04.0-2.fc24, kdelibs-4.14.19-3.fc24, kdepimlibs-4.14.10-13.fc24, kolourpaint-16.04.0-2.fc24, ksaneplugin-16.04.0-2.fc24, libkscreen-1.0.5-9.fc24, okular-16.04.0-2.fc24, phonon-4.8.3-12.fc24, plasma-breeze-5.6.3-2.fc24, plasma-oxygen-5.6.3-2.fc24, qca-2.1.1-6.fc24, qscintilla-2.9.2-3.fc24, qt-4.8.7-17.fc24, svgpart-16.04.0-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.