Bug 1319408 - /syslinux/vmlinuz0 not found at UEFI boot
Summary: /syslinux/vmlinuz0 not found at UEFI boot
Status: CLOSED DUPLICATE of bug 1318494
Alias: None
Product: Fedora
Classification: Fedora
Component: LiveCD
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-19 17:29 UTC by John Reiser
Modified: 2016-03-19 22:36 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-03-19 21:51:43 UTC


Attachments (Terms of Use)

Description John Reiser 2016-03-19 17:29:37 UTC
Description of problem: UEFI boot from USB flash memory device fails because /syslinux/vmlinuz0 is not found.  The boot stanza also specifies initrd0 which is not there, either.  Removing both trailing '0' (thus 'vmlinuz' and 'initrd') boots successfully.


Version-Release number of selected component (if applicable):
Fedora-Workstation-Live-x86_64-24_Alpha-6.iso


How reproducible: every time


Steps to Reproduce:
1. Download Workstation-Live Alpha-6
2. write to USB flash memory device using liveusb-creator
3. boot USB flash memory device in UEFI mode on bare hardware

Actual results:
error: file '/syslinux/vmlinuz0' not found
eror: you need to load the kernel first


Expected results: successful UEFI boot


Additional info: non-UEFI boot works

Comment 1 John Reiser 2016-03-19 17:35:42 UTC
liveusb-creator version 3.14.2 from Fedora 22.  This is greater than 3.11.8 which QA:Testcase_USB_stick_Live_luc mentions as the minimum for UEFI.

Comment 2 Chris Murphy 2016-03-19 21:44:45 UTC
This is likely a dup of bug 1318494, or related to it. Livecd isn't being used by the compose process anymore, livemedia-creator (part of lorax) is instead.

Comment 3 John Reiser 2016-03-19 21:51:43 UTC
Note that the proposed of using dd (in bug #1318494) might not allow for the addition of writable persistent storage on the USB flash memory device.

*** This bug has been marked as a duplicate of bug 1318494 ***

Comment 4 Chris Murphy 2016-03-19 22:36:26 UTC
Persistent overlay isn't working in livecd-tools right now, bug 1318470. And the new Live USB Creator isn't expected to have an overlay option for Fedora 24.
https://lists.fedoraproject.org/archives/list/desktop@lists.fedoraproject.org/message/2CRM2L4ZXPN63LZHDJHQSAK3R2V5MLFY/

So the question going forward is it easier to fix these problems still using lvm/dm? Or something else?

I floated using a Btrfs seed device inside the squashfs image with mbriza, which fits this use case rather well. The setup is easier and faster than an overlay file, and it also works around bug 1189345 which reportedly also can happen on Windows created sticks as well, and on all media with overlays since the present overlay file (constantly) modifies the ISO image.


Note You need to log in before you can comment on or make changes to this bug.