Bug 131959 - eject/df hangs system
Summary: eject/df hangs system
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eject   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
: 131960 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-07 13:40 UTC by Sammy
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 15:45:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2004-09-07 13:40:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; X11; en_US, en_US.UTF-8, en) (KHTML, like Gecko)

Description of problem:
Here are the steps that work every time:

1. Insert a CD
2. do a mount -t iso9660 /dev/cdrom /mnt/cdrom

The CD is mounted and shows up with "df" fine and all

3. do "eject /dev/cdrom"

The CD is ejected but you get an error message:

eject: unable to eject, last error: Invalid argument.

4. Do a "df" this just hangs and hangs eveything else.

5. Do Ctrl+Alt+F1 to switch to terminal mode

6. Try to login....it does not work and you get the messages:

 fs/jbd/transaction.c:165: spin_is_locked on uninitialized spinlock 61f565b8
 fs/jbd/transaction.c:177: spin_is_locked on uninitialized spinlock 61f565b8

These two lines keep coming....and you need to reboot.

Version-Release number of selected component (if applicable):
eject-2.0.13-9

How reproducible:
Always

Steps to Reproduce:
1. Follow steps described above
2.
3.
    

Additional info:

Comment 1 Bill Nottingham 2004-09-07 13:43:40 UTC
*** Bug 131960 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2004-10-15 15:45:35 UTC
Does this happen with current kernels?

Comment 3 Sammy 2004-10-15 16:40:25 UTC
Hi, I just tested it with 1.624 and the hang did not happen. 
 
I still get the "eject: unable to eject, last error: Invalid argument."  
message despite the fact that it is actually ejected. 

Comment 4 Bill Nottingham 2004-10-20 04:55:29 UTC
OK, kernel bug appears fixed.

Deescalating, assigning back to eject.

Comment 5 Ngo Than 2004-10-20 13:53:15 UTC
it's strange. I did not see the above error message "eject: unable to 
eject, last error: Invalid argument.", it just works for me with IDE 
CDROM. Could you please give more details about your CDROM (IDE/SCSI, 
name of CDROM)? thanks 
 
 

Comment 6 Sammy 2004-10-20 14:00:35 UTC
Here are all the dmesg stuff for the CD: 
 
hdc: HL-DT-ST GCE-8481B, ATAPI CD/DVD-ROM drive 
Using cfq io scheduler 
ide1 at 0x170-0x177,0x376 on irq 15 
Probing IDE interface ide0... 
ide0: Wait for ready failed before probe ! 
Probing IDE interface ide2... 
ide2: Wait for ready failed before probe ! 
Probing IDE interface ide3... 
ide3: Wait for ready failed before probe ! 
Probing IDE interface ide4... 
ide4: Wait for ready failed before probe ! 
Probing IDE interface ide5... 
ide5: Wait for ready failed before probe ! 
hdc: ATAPI 40X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33) 
Uniform CD-ROM driver Revision: 3.20 
 

Comment 7 Ngo Than 2004-11-02 15:45:33 UTC
the "...Invalid argument." error is fixed in eject-2.0.13-12 or newer.
thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.