Bug 131960 - eject/df hangs system
eject/df hangs system
Status: CLOSED DUPLICATE of bug 131959
Product: Fedora
Classification: Fedora
Component: eject (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-07 09:40 EDT by Sammy
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2004-09-07 09:40:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; X11; en_US, en_US.UTF-8, en) (KHTML, like Gecko)

Description of problem:
Here are the steps that work every time:

1. Insert a CD
2. do a mount -t iso9660 /dev/cdrom /mnt/cdrom

The CD is mounted and shows up with "df" fine and all

3. do "eject /dev/cdrom"

The CD is ejected but you get an error message:

eject: unable to eject, last error: Invalid argument.

4. Do a "df" this just hangs and hangs eveything else.

5. Do Ctrl+Alt+F1 to switch to terminal mode

6. Try to login....it does not work and you get the messages:

 fs/jbd/transaction.c:165: spin_is_locked on uninitialized spinlock 61f565b8
 fs/jbd/transaction.c:177: spin_is_locked on uninitialized spinlock 61f565b8

These two lines keep coming....and you need to reboot.

Version-Release number of selected component (if applicable):
eject-2.0.13-9

How reproducible:
Always

Steps to Reproduce:
1. Follow steps described above
2.
3.
    

Additional info:
Comment 1 Bill Nottingham 2004-09-07 09:43:21 EDT

*** This bug has been marked as a duplicate of 131959 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.