Bug 131975 - up2date logic error with "obsoletes", 3rd party packages
Summary: up2date logic error with "obsoletes", 3rd party packages
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 120092
TreeView+ depends on / blocked
 
Reported: 2004-09-07 16:33 UTC by Josh Kelley
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:19:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Josh Kelley 2004-09-07 16:33:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
If the RHN version of a package is marked as obsoleting a package
that's currently installed, then up2date will always try to install
that package, even a newer, 3rd-party version of the package is
already installed.  (I think this is what's happening - I may be
wrong.  See "Steps to reproduce" for the exact problem that I'm seeing.)

Version-Release number of selected component (if applicable):
up2date-4.2.38-1

How reproducible:
Always

Steps to Reproduce:
1. Build SpamAssassin 2.64 from the SRPM at
http://www.spamassassin.org/.  This creates 3 RPMs:
spamassassin-2.64-1, spamassassin-tools-2.64-1, and
perl-Mail-SpamAssassin-2.64-1.
2. Install these RPMs.  Upgrade or replace Red Hat's version of the
spamassassin RPM (2.55-3.1).
3. Run up2date.


Actual Results:  up2date says that spamassassin-2.55-3.1 obsoletes
perl-Mail-SpamAssassin-2.64-1 and tries to "upgrade" from
spamassassin-2.64-1 to spamassassin-2.55-3.1.

Expected Results:  up2date should recognize that, even if
spamassassin-2.55-3.1 says it obsoletes perl-Mail-SpamAssassin-2.64-1,
a newer version of spamassassin is already installed.  up2date should
therefore not attempt to "upgrade" from spamassassin-2.64-1 to
spamassassin-2.55-3.1.

Additional info:

Comment 1 Ronald Cole 2005-03-31 22:29:09 UTC
This bug is a duplicate of bug #118110.

Comment 2 RHEL Product and Program Management 2007-10-19 19:19:12 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.