Bug 1320126 - FC LUN of Hosted_storage is electable while creating new SD before import.
Summary: FC LUN of Hosted_storage is electable while creating new SD before import.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-4.2.1
: ---
Assignee: Nobody
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On: 1455169 1527135
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-22 11:16 UTC by Ulhas Surse
Modified: 2019-05-16 13:06 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 17:38:32 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)
Screenshot from 2018-01-24 13-59-09.png (95.53 KB, image/png)
2018-01-24 11:59 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 None None None 2018-05-15 17:40:08 UTC

Description Ulhas Surse 2016-03-22 11:16:26 UTC
Description of problem:
While creating a new FC storage domain, the FC LUN of Hosted_storage can also be elected to create storage domain on it. 

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization 3.6.3 (hosted_engine setup with FC)

How reproducible:
Always.

Steps to Reproduce:
1. Install Hosted_Engine using FC LUNs.
2. Try to create new domain, when the scan completes, Hosted_storage LUN can also be selected from the checklist. This would destroy HE env.
3. 

Actual results:
Hosted_storage LUN can be selected.

Expected results:
Hosted Storage LUN should be grayed out/ Should not be available to select.

Additional info:
Attaching screenshots.

Comment 3 Tal Nisan 2016-03-22 20:07:49 UTC
Roy, iirc you blocked this from happening, isn't it?

Comment 4 Allon Mureinik 2016-03-23 11:39:34 UTC
The auto import in 3.6 should register the domain's LUNs. Moving to SLA to take lead on this issue.

Comment 5 Roy Golan 2016-04-03 15:19:51 UTC
(In reply to Allon Mureinik from comment #4)
> The auto import in 3.6 should register the domain's LUNs. Moving to SLA to
> take lead on this issue.

If a LUN is being used by a domain, why is it available for other domain creation and won't that fail in validation stage anyway?

Comment 6 Allon Mureinik 2016-04-04 12:34:18 UTC
(In reply to Roy Golan from comment #5)
> (In reply to Allon Mureinik from comment #4)
> > The auto import in 3.6 should register the domain's LUNs. Moving to SLA to
> > take lead on this issue.
> 
> If a LUN is being used by a domain, why is it available for other domain
> creation and won't that fail in validation stage anyway?

If it's properly registered in the DB, which seems the registration isn't doing.

Comment 9 Martin Sivák 2017-08-23 10:49:38 UTC
The current plan is to take the special status from hosted engine storage domain and allow its usage for other VMs as well. All components are going to be updated to allow that and behave properly.

Comment 10 Martin Sivák 2017-11-21 09:54:00 UTC
And Node 0 deployment will remove the "before import" window as the engine will know about hosted engine objects (VM, storage domain) right from the start.

Comment 11 Martin Sivák 2017-11-27 12:37:43 UTC
Assuming Node 0 got merged in time for 4.2.0/4.2.1, please just verify that this is not possible in hosted engine deployed using the Node 0 method. There should no longer be any "before import" phase.

Comment 12 Martin Sivák 2018-01-17 11:38:26 UTC
The Node 0 deployment was made the default method by https://gerrit.ovirt.org/#/c/83900/ and this issue will not longer happen there. Please test using ansible based deployment.

Comment 13 RHV bug bot 2018-01-18 17:39:09 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.2-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.2-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 14 Nikolai Sednev 2018-01-24 11:59:49 UTC
Created attachment 1385537 [details]
Screenshot from 2018-01-24 13-59-09.png

Comment 15 Nikolai Sednev 2018-01-24 12:03:17 UTC
Works for me on these conponents on FC deployment using ansible.
ovirt-hosted-engine-ha-2.2.5-0.0.master.20180117160214.20180117160210.gitd5b58a8.el7.centos.noarch
ovirt-hosted-engine-setup-2.2.8-0.0.master.20180123120416.gitfa69a78.el7.centos.noarch
ovirt-engine-appliance-4.2-20180121.1.el7.centos.noarch
Linux 3.10.0-693.17.1.el7.x86_64 #1 SMP Sun Jan 14 10:36:03 EST 2018 x86_64 x86_64 x86_64 GNU/Linux

SHE LUN greyed out and not selectable, right after deployment is finished and there is no need of adding additional data storage domain for auto-import, for Node Zero any more.
Moving to verified.

Comment 20 errata-xmlrpc 2018-05-15 17:38:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 21 Franta Kust 2019-05-16 13:06:02 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.