Bug 1527135 - Node Zero FC deployment fails with [ ERROR ] ERROR! the playbook: /usr/share/ovirt-hosted-engine-setup/ansible/fc_getdevices.yml.
Summary: Node Zero FC deployment fails with [ ERROR ] ERROR! the playbook: /usr/share/...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.2.1
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ovirt-4.2.1
: ---
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
: 1527876 (view as bug list)
Depends On:
Blocks: 1320126 1455169 1458709
TreeView+ depends on / blocked
 
Reported: 2017-12-18 15:58 UTC by Nikolai Sednev
Modified: 2018-02-12 11:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-12 11:50:32 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
rule-engine: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
sosreport from purple-vds2 (9.44 MB, application/x-xz)
2017-12-18 15:58 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 85558 master MERGED ansible: fc: add fc_getdevices.yml to the rpm 2018-09-03 09:37:21 UTC

Description Nikolai Sednev 2017-12-18 15:58:37 UTC
Created attachment 1369565 [details]
sosreport from purple-vds2

Description of problem:
Node Zero FC deployment fails with [ ERROR ] ERROR! the playbook: /usr/share/ovirt-hosted-engine-setup/ansible/fc_getdevices.yml.

purple-vds2 ~]# ll -lsh /usr/share/ovirt-hosted-engine-setup/ansible/
total 44K
 12K -rw-r--r--. 1 root root 8.3K Dec 14 17:47 bootstrap_local_vm.yml
   0 drwxr-xr-x. 2 root root   77 Dec 18 17:00 callback_plugins
4.0K -rw-r--r--. 1 root root 1.1K Dec 14 17:47 clean_environment.yml
8.0K -rw-r--r--. 1 root root 5.2K Dec 14 17:47 create_storage_domain.yml
 12K -rw-r--r--. 1 root root  12K Dec 14 17:47 create_target_vm.yml
4.0K -rw-r--r--. 1 root root  588 Dec 14 17:47 iscsi_discover.yml
4.0K -rw-r--r--. 1 root root 1.2K Dec 14 17:47 iscsi_getdevices.yml
   0 drwxr-xr-x. 2 root root  104 Dec 18 17:00 library
   0 drwxr-xr-x. 2 root root  249 Dec 18 17:00 templates


Version-Release number of selected component (if applicable):
sanlock-3.5.0-1.el7.x86_64
ovirt-engine-appliance-4.2-20171217.1.el7.centos.noarch
ovirt-vmconsole-host-1.0.4-1.el7.noarch
mom-0.5.11-1.el7.noarch
ovirt-setup-lib-1.1.5-0.0.master.20170823122959.git1480342.el7.centos.noarch
vdsm-4.20.9-57.git5e0dd4b.el7.centos.x86_64
ovirt-provider-ovn-driver-1.2.2-1.el7.centos.noarch
ovirt-host-4.2.0-1.1.master.20171130100954.git90161e9.el7.centos.x86_64
ovirt-engine-sdk-python-3.6.9.2-0.1.20161204.gite99bbd1.el7.centos.noarch
ovirt-release-master-4.2.1-0.0.master.20171218000029.git96e5658.el7.centos.noarch
ovirt-host-deploy-1.7.1-0.0.master.20171128145303.gite36ef57.el7.centos.noarch
libvirt-client-3.2.0-14.el7_4.5.x86_64
ovirt-imageio-daemon-1.2.1-0.201712132007.git2af88b0.el7.centos.noarch
ovirt-hosted-engine-setup-2.2.3-0.0.master.20171214154648.git4c8befa.el7.centos.noarch
ovirt-imageio-common-1.2.1-0.201712132007.git2af88b0.el7.centos.noarch
ovirt-vmconsole-1.0.4-1.el7.noarch
ovirt-host-dependencies-4.2.0-1.1.master.20171130100954.git90161e9.el7.centos.x86_64
ovirt-hosted-engine-ha-2.2.2-1.el7.centos.noarch
Linux version 3.10.0-693.15.1.el7.x86_64 (mockbuild@x86-019.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-16) (GCC) ) #1 SMP Thu Dec 14 05:13:32 EST 2017
Linux purple-vds2.qa.lab.tlv.redhat.com 3.10.0-693.15.1.el7.x86_64 #1 SMP Thu Dec 14 05:13:32 EST 2017 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.4 (Maipo)


How reproducible:
100%

Steps to Reproduce:
1.Deploy Node Zero SHE over FC.

Actual results:
Deployment fails.

Expected results:
Deployment should succeed.

Additional info:
Sosreport from host and deployment details.
http://pastebin.test.redhat.com/541690

Comment 1 Nikolai Sednev 2017-12-21 08:39:44 UTC
*** Bug 1527876 has been marked as a duplicate of this bug. ***

Comment 2 Nikolai Sednev 2018-01-24 12:05:56 UTC
Deployment worked just fine over FC, on these components:
ovirt-hosted-engine-ha-2.2.5-0.0.master.20180117160214.20180117160210.gitd5b58a8.el7.centos.noarch
ovirt-hosted-engine-setup-2.2.8-0.0.master.20180123120416.gitfa69a78.el7.centos.noarch
ovirt-engine-appliance-4.2-20180121.1.el7.centos.noarch
Linux 3.10.0-693.17.1.el7.x86_64 #1 SMP Sun Jan 14 10:36:03 EST 2018 x86_64 x86_64 x86_64 GNU/Linux

We may move this bug to verified.

Comment 3 Simone Tiraboschi 2018-01-24 12:39:55 UTC
Yes, please.

Comment 4 Nikolai Sednev 2018-01-24 12:53:21 UTC
Moving to verified.

Comment 5 Sandro Bonazzola 2018-02-12 11:50:32 UTC
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.